aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/util-linux/patches/120-meson-get-the-project-version-from-the-version-gen-s.patch
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2022-04-29 18:41:45 -0700
committerChristian Lamparter <chunkeey@gmail.com>2022-05-15 16:32:40 +0200
commit28cec438071c6a5ce90ed4606df7cbe6ad8a100c (patch)
treeaa75aebe9476cd17c90e64f7f53b0fa3c3675569 /package/utils/util-linux/patches/120-meson-get-the-project-version-from-the-version-gen-s.patch
parentd93aae1d675caf47fbec684d12e39fb4090527d5 (diff)
downloadupstream-28cec438071c6a5ce90ed4606df7cbe6ad8a100c.tar.gz
upstream-28cec438071c6a5ce90ed4606df7cbe6ad8a100c.tar.bz2
upstream-28cec438071c6a5ce90ed4606df7cbe6ad8a100c.zip
util-linux: use meson to build
Compiles faster, is PIC by default, and does not have pkgconfig files with wrong paths. Add various fixes to it as it seems cross compilation was never tested. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'package/utils/util-linux/patches/120-meson-get-the-project-version-from-the-version-gen-s.patch')
-rw-r--r--package/utils/util-linux/patches/120-meson-get-the-project-version-from-the-version-gen-s.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/package/utils/util-linux/patches/120-meson-get-the-project-version-from-the-version-gen-s.patch b/package/utils/util-linux/patches/120-meson-get-the-project-version-from-the-version-gen-s.patch
new file mode 100644
index 0000000000..8529c8268e
--- /dev/null
+++ b/package/utils/util-linux/patches/120-meson-get-the-project-version-from-the-version-gen-s.patch
@@ -0,0 +1,20 @@
+From e0c1a86bf88b568a7afe8ebaea1b9f84afb892c2 Mon Sep 17 00:00:00 2001
+From: Eli Schwartz <eschwartz@archlinux.org>
+Date: Wed, 4 May 2022 23:52:31 -0400
+Subject: [PATCH] meson: get the project version from the version-gen script
+
+This matches autotools and ensures that the version number is actually
+reliable.
+---
+ meson.build | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- a/meson.build
++++ b/meson.build
+@@ -1,5 +1,5 @@
+ project('util-linux', 'c',
+- version : '2.37',
++ version : run_command('tools/git-version-gen', check: true).stdout(),
+ license : 'GPLv2+')
+
+ pkgconfig = import('pkgconfig')