aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/px5g/Makefile
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2020-08-29 21:37:29 -1000
committerDaniel Golle <daniel@makrotopia.org>2020-08-31 10:19:31 +0100
commit976d3e22349c9da607777ad364c8639b5c531e04 (patch)
treee83ac371ada392e3ce2fbfd4129f83aae0ded401 /package/utils/px5g/Makefile
parent7078294b59ccbbddf641f80efa743095ca275530 (diff)
downloadupstream-976d3e22349c9da607777ad364c8639b5c531e04.tar.gz
upstream-976d3e22349c9da607777ad364c8639b5c531e04.tar.bz2
upstream-976d3e22349c9da607777ad364c8639b5c531e04.zip
px5g: rename to px5g-mbedtls
Two versions of `px5g` exists without sharing code. For clarification rename the previously existing MbedTLS based version to `px5g-mbedtls` to exists next to `px5g-wolfssl`. Rename code file of MbedTLS from `px5g.c` to `px5g-mbedtls.c`. Signed-off-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'package/utils/px5g/Makefile')
-rw-r--r--package/utils/px5g/Makefile69
1 files changed, 0 insertions, 69 deletions
diff --git a/package/utils/px5g/Makefile b/package/utils/px5g/Makefile
deleted file mode 100644
index f4be6cb5ee..0000000000
--- a/package/utils/px5g/Makefile
+++ /dev/null
@@ -1,69 +0,0 @@
-#
-# Copyright (C) 2010-2015 Jo-Philipp Wich <jo@mein.io>
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=px5g
-PKG_RELEASE:=9
-PKG_LICENSE:=LGPL-2.1
-
-PKG_USE_MIPS16:=0
-
-PKG_MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/px5g-mbedtls
- SECTION:=utils
- CATEGORY:=Utilities
- SUBMENU:=Encryption
- TITLE:=X.509 certificate generator (using mbedtls)
- DEPENDS:=+libmbedtls
- PROVIDES:=px5g
- VARIANT:=mbedtls
-endef
-
-define Package/px5g-mbedtls/description
- Px5g is a tiny standalone X.509 certificate generator.
- It suitable to create key files and certificates in DER
- and PEM format for use with stunnel, uhttpd and others.
-endef
-
-define Package/px5g-standalone
- SECTION:=utils
- CATEGORY:=Utilities
- SUBMENU:=Encryption
- TITLE:=X.509 certificate generator (standalone)
- VARIANT:=standalone
-endef
-Package/px5g-standalone/description = $(Package/px5g-mbedtls/description)
-
-define Build/Prepare
- mkdir -p $(PKG_BUILD_DIR)
-endef
-
-TARGET_LDFLAGS += -lmbedtls -lmbedx509 -lmbedcrypto
-
-ifeq ($(BUILD_VARIANT),standalone)
- TARGET_LDFLAGS := -Wl,-Bstatic $(TARGET_LDFLAGS) -Wl,-Bdynamic
-endif
-
-TARGET_CFLAGS += -Wl,--gc-sections -Wall -Werror
-
-define Build/Compile
- $(TARGET_CC) $(TARGET_CPPFLAGS) $(TARGET_CFLAGS) -o $(PKG_BUILD_DIR)/px5g px5g.c $(TARGET_LDFLAGS)
-endef
-
-define Package/px5g-mbedtls/install
- $(INSTALL_DIR) $(1)/usr/sbin
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/px5g $(1)/usr/sbin/px5g
-endef
-
-Package/px5g-standalone/install = $(Package/px5g-mbedtls/install)
-
-$(eval $(call BuildPackage,px5g-mbedtls))
-$(eval $(call BuildPackage,px5g-standalone))