aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/px5g/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-01-09 14:28:43 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-09 14:35:08 +0100
commit1cf64e210f3699af57310478179dcc4108825c58 (patch)
tree90dad7f02faa0f8c91e27b2eabbce30f6099e205 /package/utils/px5g/Makefile
parent018d80007e6d9469077d938872e605f826010767 (diff)
downloadupstream-1cf64e210f3699af57310478179dcc4108825c58.tar.gz
upstream-1cf64e210f3699af57310478179dcc4108825c58.tar.bz2
upstream-1cf64e210f3699af57310478179dcc4108825c58.zip
px5g: remove legacy polarssl support
The old polarssl 1.3 branch is EOL since end of 2016, and the package for it will be removed soon. Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/utils/px5g/Makefile')
-rw-r--r--package/utils/px5g/Makefile23
1 files changed, 5 insertions, 18 deletions
diff --git a/package/utils/px5g/Makefile b/package/utils/px5g/Makefile
index c5de03a02c..23fb0e1b1f 100644
--- a/package/utils/px5g/Makefile
+++ b/package/utils/px5g/Makefile
@@ -16,48 +16,35 @@ PKG_USE_MIPS16:=0
include $(INCLUDE_DIR)/package.mk
-define Package/px5g/Template
+define Package/px5g-mbedtls
SECTION:=utils
CATEGORY:=Utilities
SUBMENU:=Encryption
- TITLE:=X.509 certificate generator (using $(1))
+ TITLE:=X.509 certificate generator (using mbedtls)
MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
- DEPENDS:=+lib$(1)
+ DEPENDS:=+libmbedtls
PROVIDES:=px5g
- VARIANT:=$(1)
endef
-define Package/px5g-polarssl/description
+define Package/px5g-mbedtls/description
Px5g is a tiny standalone X.509 certificate generator.
It suitable to create key files and certificates in DER
and PEM format for use with stunnel, uhttpd and others.
endef
-Package/px5g-mbedtls=$(call Package/px5g/Template,mbedtls)
-Package/px5g-polarssl=$(call Package/px5g/Template,polarssl)
-Package/px5g-mbedtls/description=$(Package/px5g-polarssl/description)
-
define Build/Prepare
mkdir -p $(PKG_BUILD_DIR)
endef
-ifeq ($(BUILD_VARIANT),mbedtls)
-TARGET_CFLAGS += -DMBEDTLS
TARGET_LDFLAGS := -lmbedtls -lmbedx509 -lmbedcrypto
-else
-TARGET_LDFLAGS := -lpolarssl
-endif
define Build/Compile
$(TARGET_CC) $(TARGET_CFLAGS) -o $(PKG_BUILD_DIR)/px5g px5g.c $(TARGET_LDFLAGS)
endef
-define Package/px5g-polarssl/install
+define Package/px5g-mbedtls/install
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/px5g $(1)/usr/sbin/px5g
endef
-Package/px5g-mbedtls/install=$(Package/px5g-polarssl/install)
-
-$(eval $(call BuildPackage,px5g-polarssl))
$(eval $(call BuildPackage,px5g-mbedtls))