aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/px5g-standalone/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-02-21 14:24:32 +0100
committerJo-Philipp Wich <jo@mein.io>2017-03-01 20:37:37 +0100
commit0f2757dce4f555e53e80e8238810c9419336758b (patch)
tree5bd5fcb2dfdf098ff28a4cfe51351378a8ff8e26 /package/utils/px5g-standalone/Makefile
parent2e8545333a356a413c44fd8c673039807b780c42 (diff)
downloadupstream-0f2757dce4f555e53e80e8238810c9419336758b.tar.gz
upstream-0f2757dce4f555e53e80e8238810c9419336758b.tar.bz2
upstream-0f2757dce4f555e53e80e8238810c9419336758b.zip
px5g: replace px5g-standalone with a statically linked variant of px5g-mbedtls
px5g-standalone only supports SHA1 for certificates, which is strongly deprecated. The new px5g-standalone is about 27k bigger (compressed), and has identical behavior to px5g-mbedtls (it uses SHA256). Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/utils/px5g-standalone/Makefile')
-rw-r--r--package/utils/px5g-standalone/Makefile36
1 files changed, 0 insertions, 36 deletions
diff --git a/package/utils/px5g-standalone/Makefile b/package/utils/px5g-standalone/Makefile
deleted file mode 100644
index 9b878ae336..0000000000
--- a/package/utils/px5g-standalone/Makefile
+++ /dev/null
@@ -1,36 +0,0 @@
-#
-# Copyright (C) 2010-2014 Jo-Philipp Wich <xm@subsignal.org>
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=px5g-standalone
-PKG_RELEASE:=2
-
-PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/px5g-standalone
- SECTION:=utils
- CATEGORY:=Utilities
- SUBMENU:=Encryption
- TITLE:=X.509 certificate generator (standalone version)
- MAINTAINER:=Jo-Philipp Wich <xm@subsignal.org>
-endef
-
-define Package/px5g-standalone/description
- Px5g is a tiny standalone X.509 certificate generator.
- It suitable to create key files and certificates in DER
- and PEM format for use with stunnel, uhttpd and others.
-endef
-
-define Package/px5g-standalone/install
- $(INSTALL_DIR) $(1)/usr/sbin
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/px5g $(1)/usr/sbin/px5g
-endef
-
-$(eval $(call BuildPackage,px5g-standalone))