aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/otrx/Makefile
diff options
context:
space:
mode:
authorRafał Miłecki <zajec5@gmail.com>2015-04-09 05:21:55 +0000
committerRafał Miłecki <zajec5@gmail.com>2015-04-09 05:21:55 +0000
commit9b112b4e0079bb8a379e8595a91b46ea1c7a42b1 (patch)
tree197c63b3476db1718a71b648238ffe0e949db271 /package/utils/otrx/Makefile
parent8c027356bc164c2f3c1ad526d9f0e5e2baa66c20 (diff)
downloadupstream-9b112b4e0079bb8a379e8595a91b46ea1c7a42b1.tar.gz
upstream-9b112b4e0079bb8a379e8595a91b46ea1c7a42b1.tar.bz2
upstream-9b112b4e0079bb8a379e8595a91b46ea1c7a42b1.zip
otrx: new package with tiny app verifying TRX images
Signed-off-by: Rafał Miłecki <zajec5@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45315 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/utils/otrx/Makefile')
-rw-r--r--package/utils/otrx/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/package/utils/otrx/Makefile b/package/utils/otrx/Makefile
new file mode 100644
index 0000000000..360fb1790d
--- /dev/null
+++ b/package/utils/otrx/Makefile
@@ -0,0 +1,43 @@
+#
+# Copyright (C) 2015 Rafał Miłecki <zajec5@gmail.com>
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=otrx
+PKG_RELEASE:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/otrx
+ SECTION:=utils
+ CATEGORY:=Base system
+ TITLE:=Utility for opening (analyzing) TRX firmware images
+ MAINTAINER:=Rafał Miłecki <zajec5@gmail.com>
+ DEPENDS:=@TARGET_brcm47xx||@TARGET_bcm53xx
+endef
+
+define Package/otrx/description
+ This package contains an utility that allows validating TRX images.
+endef
+
+define Build/Prepare
+ mkdir -p $(PKG_BUILD_DIR)
+ $(CP) ./src/* $(PKG_BUILD_DIR)/
+endef
+
+define Build/Compile
+ $(MAKE) -C $(PKG_BUILD_DIR) \
+ CC="$(TARGET_CC)" \
+ CFLAGS="$(TARGET_CFLAGS) -Wall"
+endef
+
+define Package/otrx/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/otrx $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,otrx))