aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/fuse
diff options
context:
space:
mode:
authorPaul Wassi <p.wassi@gmx.at>2016-11-22 09:43:24 +0100
committerFelix Fietkau <nbd@nbd.name>2016-11-24 12:53:17 +0100
commit4081333084a4e52a125f678e905dbbcccb9e4bd0 (patch)
tree269928577a7fd5f8f92a4c83317feaad1e973667 /package/utils/fuse
parent539ae47103b7de5cecb1a94beab0acb97ef7df1d (diff)
downloadupstream-4081333084a4e52a125f678e905dbbcccb9e4bd0.tar.gz
upstream-4081333084a4e52a125f678e905dbbcccb9e4bd0.tar.bz2
upstream-4081333084a4e52a125f678e905dbbcccb9e4bd0.zip
package/utils/fuse: update to 2.9.7
Update fuse+libfuse to upstream 2.9.7. Drop the patch for CVE-2015-3202, which is already integrated in the newer version. Rework the other patches. Also switch PKG_SOURCE from @SF to libfuse's github releases. Signed-off-by: Paul Wassi <p.wassi@gmx.at>
Diffstat (limited to 'package/utils/fuse')
-rw-r--r--package/utils/fuse/Makefile8
-rw-r--r--package/utils/fuse/patches/001-fix_exec_environment_for_mount_and_umount.patch59
-rw-r--r--package/utils/fuse/patches/100-missing_includes.patch10
-rw-r--r--package/utils/fuse/patches/112-no_break_on_mknod.patch2
4 files changed, 5 insertions, 74 deletions
diff --git a/package/utils/fuse/Makefile b/package/utils/fuse/Makefile
index 9adb6d3ec6..19eba3c18d 100644
--- a/package/utils/fuse/Makefile
+++ b/package/utils/fuse/Makefile
@@ -9,12 +9,12 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=fuse
-PKG_VERSION:=2.9.3
-PKG_RELEASE:=2
+PKG_VERSION:=2.9.7
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=@SF/$(PKG_NAME)
-PKG_MD5SUM:=33cae22ca50311446400daf8a6255c6a
+PKG_SOURCE_URL:=https://github.com/libfuse/libfuse/releases/download/$(PKG_NAME)-$(PKG_VERSION)
+PKG_MD5SUM:=9bd4ce8184745fd3d000ca2692adacdb
PKG_LICENSE:=LGPLv2.1 GPLv2
PKG_LICENSE_FILES:=COPYING.LIB COPYING
diff --git a/package/utils/fuse/patches/001-fix_exec_environment_for_mount_and_umount.patch b/package/utils/fuse/patches/001-fix_exec_environment_for_mount_and_umount.patch
deleted file mode 100644
index 392bb5e2a8..0000000000
--- a/package/utils/fuse/patches/001-fix_exec_environment_for_mount_and_umount.patch
+++ /dev/null
@@ -1,59 +0,0 @@
-From cfe13b7a217075ae741c018da50cd600e5330de2 Mon Sep 17 00:00:00 2001
-From: Miklos Szeredi <mszeredi@suse.cz>
-Date: Fri, 22 May 2015 10:58:43 +0200
-Subject: [PATCH] libfuse: fix exec environment for mount and umount
-
-Found by Tavis Ormandy (CVE-2015-3202).
----
---- a/lib/mount_util.c
-+++ b/lib/mount_util.c
-@@ -95,10 +95,12 @@ static int add_mount(const char *prognam
- goto out_restore;
- }
- if (res == 0) {
-+ char *env = NULL;
-+
- sigprocmask(SIG_SETMASK, &oldmask, NULL);
- setuid(geteuid());
-- execl("/bin/mount", "/bin/mount", "--no-canonicalize", "-i",
-- "-f", "-t", type, "-o", opts, fsname, mnt, NULL);
-+ execle("/bin/mount", "/bin/mount", "--no-canonicalize", "-i",
-+ "-f", "-t", type, "-o", opts, fsname, mnt, NULL, &env);
- fprintf(stderr, "%s: failed to execute /bin/mount: %s\n",
- progname, strerror(errno));
- exit(1);
-@@ -146,10 +148,17 @@ static int exec_umount(const char *progn
- goto out_restore;
- }
- if (res == 0) {
-+ char *env = NULL;
-+
- sigprocmask(SIG_SETMASK, &oldmask, NULL);
- setuid(geteuid());
-- execl("/bin/umount", "/bin/umount", "-i", rel_mnt,
-- lazy ? "-l" : NULL, NULL);
-+ if (lazy) {
-+ execle("/bin/umount", "/bin/umount", "-i", rel_mnt,
-+ "-l", NULL, &env);
-+ } else {
-+ execle("/bin/umount", "/bin/umount", "-i", rel_mnt,
-+ NULL, &env);
-+ }
- fprintf(stderr, "%s: failed to execute /bin/umount: %s\n",
- progname, strerror(errno));
- exit(1);
-@@ -205,10 +214,12 @@ static int remove_mount(const char *prog
- goto out_restore;
- }
- if (res == 0) {
-+ char *env = NULL;
-+
- sigprocmask(SIG_SETMASK, &oldmask, NULL);
- setuid(geteuid());
-- execl("/bin/umount", "/bin/umount", "--no-canonicalize", "-i",
-- "--fake", mnt, NULL);
-+ execle("/bin/umount", "/bin/umount", "--no-canonicalize", "-i",
-+ "--fake", mnt, NULL, &env);
- fprintf(stderr, "%s: failed to execute /bin/umount: %s\n",
- progname, strerror(errno));
- exit(1);
diff --git a/package/utils/fuse/patches/100-missing_includes.patch b/package/utils/fuse/patches/100-missing_includes.patch
index 0790bffcd1..e74a1870f0 100644
--- a/package/utils/fuse/patches/100-missing_includes.patch
+++ b/package/utils/fuse/patches/100-missing_includes.patch
@@ -1,13 +1,3 @@
---- a/lib/mount_util.c
-+++ b/lib/mount_util.c
-@@ -16,6 +16,7 @@
- #include <errno.h>
- #include <fcntl.h>
- #include <limits.h>
-+#include <paths.h>
- #ifndef __NetBSD__
- #include <mntent.h>
- #endif
--- a/include/fuse.h
+++ b/include/fuse.h
@@ -32,6 +32,7 @@
diff --git a/package/utils/fuse/patches/112-no_break_on_mknod.patch b/package/utils/fuse/patches/112-no_break_on_mknod.patch
index 33f7c6c2a1..f679c4116d 100644
--- a/package/utils/fuse/patches/112-no_break_on_mknod.patch
+++ b/package/utils/fuse/patches/112-no_break_on_mknod.patch
@@ -1,6 +1,6 @@
--- a/util/Makefile.in
+++ b/util/Makefile.in
-@@ -676,7 +676,7 @@ mount_util.c: $(top_srcdir)/lib/mount_ut
+@@ -723,7 +723,7 @@ mount_util.c: $(top_srcdir)/lib/mount_ut
install-exec-hook:
-chmod u+s $(DESTDIR)$(bindir)/fusermount