aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/fritz-tools/src/CMakeLists.txt
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2017-03-25 18:09:37 +0100
committerMathias Kresin <dev@kresin.me>2017-04-08 14:30:00 +0200
commit8b3fa168b49a4aad5797ef5083c17c348d99731b (patch)
treed7eac940d191855a585876a1a8018549981ca04d /package/utils/fritz-tools/src/CMakeLists.txt
parent136718a3d91bb392de8bc04d9fd59d86b4f460c0 (diff)
downloadupstream-8b3fa168b49a4aad5797ef5083c17c348d99731b.tar.gz
upstream-8b3fa168b49a4aad5797ef5083c17c348d99731b.tar.bz2
upstream-8b3fa168b49a4aad5797ef5083c17c348d99731b.zip
firmware: rework fritz-tools package
Split the fritz-tools into subpackages. fritz_tffs_read is usefull for all Fritz boards where fritz-cal_extract is only required for the Fritz 4040 at the moment. Rename the tffs related binary to the more catchy name fritz_tffs and move the whole package to utilities since the package doesn't really provide a firmware file. Make the fritz-tools available for all targets and build them shared. The tffs is used by avm on lantiq and ar71xx as well. Tested-by: Christian Lamparter <chunkeey@googlemail.com> Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'package/utils/fritz-tools/src/CMakeLists.txt')
-rw-r--r--package/utils/fritz-tools/src/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/package/utils/fritz-tools/src/CMakeLists.txt b/package/utils/fritz-tools/src/CMakeLists.txt
new file mode 100644
index 0000000000..116bca9dc0
--- /dev/null
+++ b/package/utils/fritz-tools/src/CMakeLists.txt
@@ -0,0 +1,12 @@
+cmake_minimum_required(VERSION 2.6)
+
+PROJECT(fritz-tools C)
+ADD_DEFINITIONS(-Wall -Werror --std=gnu99 -Wmissing-declarations)
+
+SET(CMAKE_SHARED_LIBRARY_LINK_C_FLAGS "")
+
+ADD_EXECUTABLE(fritz_tffs_read fritz_tffs_read.c)
+ADD_EXECUTABLE(fritz_cal_extract fritz_cal_extract.c)
+TARGET_LINK_LIBRARIES(fritz_cal_extract z)
+
+INSTALL(TARGETS fritz_tffs_read fritz_cal_extract RUNTIME DESTINATION bin)