aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/fritz-tools/Makefile
diff options
context:
space:
mode:
authorAndy Binder <AndyBinder@gmx.de>2019-01-24 17:53:13 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2019-03-10 16:49:23 +0100
commit50717510e7e556cbc9ef05887900a7dc93a57793 (patch)
tree82e23ed3e66691338856b0bd7c94b3b2f0bb5ab3 /package/utils/fritz-tools/Makefile
parent445ca981d163d54c8dcf16cf206bc44904160b99 (diff)
downloadupstream-50717510e7e556cbc9ef05887900a7dc93a57793.tar.gz
upstream-50717510e7e556cbc9ef05887900a7dc93a57793.tar.bz2
upstream-50717510e7e556cbc9ef05887900a7dc93a57793.zip
fritz-tools: add fritz_tffs_nand_read tool
A tool for reading the TFFS partitions (a name-value storage usually found in AVM Fritz!Box based devices) on nand flash. Copyright (c) 2018 Valentin Spreckels <Valentin.Spreckels@Informatik.Uni-Oldenburg.DE> Based on the fritz_tffs_read tool: Copyright (c) 2015-2016 Martin Blumenstingl <martin.blumenstingl@googlemail.com> and on the TFFS 2.0 kernel driver from AVM: Copyright (c) 2004-2007 AVM GmbH <fritzbox_info@avm.de> and the TFFS 3.0 kernel driver from AVM: Copyright (C) 2004-2014 AVM GmbH <fritzbox_info@avm.de> and the OpenWrt TFFS kernel driver: Copyright (c) 2013 John Crispin <blogic@openwrt.org> This program is free software; you can redistribute it and/or modify it under the terms of the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version. This program is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License for more details. You should have received a copy of the GNU General Public License along with this program; if not, write to the Free Software Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA. Signed-off-by: Valentin Spreckels <Valentin.Spreckels@Informatik.Uni-Oldenburg.de> Signed-off-by: Andy Binder <AndyBinder@gmx.de>
Diffstat (limited to 'package/utils/fritz-tools/Makefile')
-rw-r--r--package/utils/fritz-tools/Makefile15
1 files changed, 15 insertions, 0 deletions
diff --git a/package/utils/fritz-tools/Makefile b/package/utils/fritz-tools/Makefile
index 7c547e6f97..a4d69bdf71 100644
--- a/package/utils/fritz-tools/Makefile
+++ b/package/utils/fritz-tools/Makefile
@@ -21,6 +21,15 @@ define Package/fritz-tffs/description
Utility to partially read the TFFS filesystems.
endef
+define Package/fritz-tffs-nand
+ $(call Package/fritz-tools/Default)
+ TITLE:=Utility to partially read the TFFS filesystems on NAND flash
+endef
+
+define Package/fritz-tffs-nand/description
+ Utility to partially read the TFFS filesystems on NAND flash.
+endef
+
define Package/fritz-caldata
$(call Package/fritz-tools/Default)
DEPENDS:=+zlib
@@ -36,10 +45,16 @@ define Package/fritz-tffs/install
$(INSTALL_BIN) $(PKG_BUILD_DIR)/fritz_tffs_read $(1)/usr/bin/fritz_tffs
endef
+define Package/fritz-tffs-nand/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/fritz_tffs_nand_read $(1)/usr/bin/fritz_tffs_nand
+endef
+
define Package/fritz-caldata/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/fritz_cal_extract $(1)/usr/bin/
endef
$(eval $(call BuildPackage,fritz-tffs))
+$(eval $(call BuildPackage,fritz-tffs-nand))
$(eval $(call BuildPackage,fritz-caldata))