aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/busybox
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-04-04 15:05:11 +0200
committerFelix Fietkau <nbd@nbd.name>2017-04-04 15:06:14 +0200
commit3169a6a7ada17e2ea8ef4641edee68134c04b92b (patch)
tree33316c2211305677c8b99356acad63116b23b0d5 /package/utils/busybox
parentf6433eede79db4f6276b68e815bb17a9364292c7 (diff)
downloadupstream-3169a6a7ada17e2ea8ef4641edee68134c04b92b.tar.gz
upstream-3169a6a7ada17e2ea8ef4641edee68134c04b92b.tar.bz2
upstream-3169a6a7ada17e2ea8ef4641edee68134c04b92b.zip
busybox: fix installation of cron and ntpd scripts in the default config
Fixes: 0b24850e9778 ("busybox: don't install NTP scripts if NTP isn't configured") Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/utils/busybox')
-rw-r--r--package/utils/busybox/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/utils/busybox/Makefile b/package/utils/busybox/Makefile
index 48d945718a..be4b967a47 100644
--- a/package/utils/busybox/Makefile
+++ b/package/utils/busybox/Makefile
@@ -112,10 +112,10 @@ endef
define Package/busybox/install
$(INSTALL_DIR) $(1)/etc/init.d
$(CP) $(PKG_INSTALL_DIR)/* $(1)/
-ifneq ($(CONFIG_BUSYBOX_CONFIG_CROND),)
+ifneq ($(CONFIG_BUSYBOX_$(BUSYBOX_SYM)_CROND),)
$(INSTALL_BIN) ./files/cron $(1)/etc/init.d/cron
endif
-ifneq ($(CONFIG_BUSYBOX_CONFIG_NTPD),)
+ifneq ($(CONFIG_BUSYBOX_$(BUSYBOX_SYM)_NTPD),)
$(INSTALL_BIN) ./files/sysntpd $(1)/etc/init.d/sysntpd
$(INSTALL_BIN) ./files/ntpd-hotplug $(1)/usr/sbin/ntpd-hotplug
endif