aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/busybox/Makefile
diff options
context:
space:
mode:
authorFlorian Fainelli <f.fainelli@gmail.com>2017-04-12 09:02:30 -0700
committerFlorian Fainelli <f.fainelli@gmail.com>2017-04-12 09:12:18 -0700
commit7ae58bebc811a0ac6734405e9bc47533939d61d7 (patch)
treeae445062ae08e4ee90bd55c8dafc1cb8a95d72bb /package/utils/busybox/Makefile
parent7d4147d86908b36dd8915bfeeb1c48c2a40941a5 (diff)
downloadupstream-7ae58bebc811a0ac6734405e9bc47533939d61d7.tar.gz
upstream-7ae58bebc811a0ac6734405e9bc47533939d61d7.tar.bz2
upstream-7ae58bebc811a0ac6734405e9bc47533939d61d7.zip
busybox: Move libresolv detection to LEDE Makefile
Since the LEDE nslookup applet is already specific to LEDE, move the libresolv detection into the busybox Makefile that LEDE uses. This fixes builds with external toolchains that don't automatically search for headers and/or libraries without being told so. Fixes: de5b8e5d2fe1 ("busybox: add musl compatible nslookup replacement") Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
Diffstat (limited to 'package/utils/busybox/Makefile')
-rw-r--r--package/utils/busybox/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/utils/busybox/Makefile b/package/utils/busybox/Makefile
index be4b967a47..c87243b93c 100644
--- a/package/utils/busybox/Makefile
+++ b/package/utils/busybox/Makefile
@@ -85,6 +85,12 @@ ifdef CONFIG_BUSYBOX_CONFIG_PAM
LDLIBS += pam pam_misc pthread
endif
+ifdef CONFIG_BUSYBOX_DEFAULT_NSLOOKUP_LEDE
+ ifeq ($(CONFIG_USE_GLIBC),y)
+ LDLIBS += resolv
+ endif
+endif
+
define Build/Compile
+$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
CC="$(TARGET_CC)" \