aboutsummaryrefslogtreecommitdiffstats
path: root/package/util-linux/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-11-29 11:13:32 +0000
committerNicolas Thill <nico@openwrt.org>2005-11-29 11:13:32 +0000
commit5157d76e86612cad7eb24f0237fa576d0c20bf9b (patch)
treeb1a54a1967d505638ba27cfd4b67b05fc44f3cd0 /package/util-linux/Makefile
parent75c3beebecd85feff6fab26e4ff9fbaf8326d8fb (diff)
downloadupstream-5157d76e86612cad7eb24f0237fa576d0c20bf9b.tar.gz
upstream-5157d76e86612cad7eb24f0237fa576d0c20bf9b.tar.bz2
upstream-5157d76e86612cad7eb24f0237fa576d0c20bf9b.zip
add a losetup package, cosmetic fixes on package descriptions
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@2567 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/util-linux/Makefile')
-rw-r--r--package/util-linux/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/util-linux/Makefile b/package/util-linux/Makefile
index ad5dd19dba..7eb180173e 100644
--- a/package/util-linux/Makefile
+++ b/package/util-linux/Makefile
@@ -19,6 +19,7 @@ PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
include $(TOPDIR)/package/rules.mk
$(eval $(call PKG_template,FDISK,fdisk,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,LOSETUP,losetup,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
$(eval $(call PKG_template,SWAP_UTILS,swap-utils,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
$(PKG_BUILD_DIR)/.configured:
@@ -47,6 +48,12 @@ $(IPKG_FDISK):
$(RSTRIP) $(IDIR_FDISK)
$(IPKG_BUILD) $(IDIR_FDISK) $(PACKAGE_DIR)
+$(IPKG_LOSETUP):
+ install -d -m0755 $(IDIR_LOSETUP)/usr/sbin
+ cp -fpR $(PKG_INSTALL_DIR)/sbin/losetup $(IDIR_LOSETUP)/usr/sbin/
+ $(RSTRIP) $(IDIR_LOSETUP)
+ $(IPKG_BUILD) $(IDIR_LOSETUP) $(PACKAGE_DIR)
+
$(IPKG_SWAP_UTILS):
install -d -m0755 $(IDIR_SWAP_UTILS)/usr/sbin
cp -fpR $(PKG_INSTALL_DIR)/sbin/mkswap $(IDIR_SWAP_UTILS)/usr/sbin/