aboutsummaryrefslogtreecommitdiffstats
path: root/package/usbreset/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-01-29 10:48:46 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-01-29 10:48:46 +0000
commita0636310f8752b147ee0d1a769b6a8bcb603b2bc (patch)
tree0f48a0a61f7d54fb9e21ede8cb0d65c5c82149ea /package/usbreset/Makefile
parenteeb60d018ac3006b6e5b32e5ba29862743afe638 (diff)
downloadupstream-a0636310f8752b147ee0d1a769b6a8bcb603b2bc.tar.gz
upstream-a0636310f8752b147ee0d1a769b6a8bcb603b2bc.tar.bz2
upstream-a0636310f8752b147ee0d1a769b6a8bcb603b2bc.zip
move a few packages to system/utils
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@35375 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/usbreset/Makefile')
-rw-r--r--package/usbreset/Makefile44
1 files changed, 0 insertions, 44 deletions
diff --git a/package/usbreset/Makefile b/package/usbreset/Makefile
deleted file mode 100644
index 75bfd85138..0000000000
--- a/package/usbreset/Makefile
+++ /dev/null
@@ -1,44 +0,0 @@
-#
-# Copyright (C) 2011-2012 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=usbreset
-PKG_RELEASE:=2
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/usbreset
- SECTION:=utils
- CATEGORY:=Utilities
- TITLE:=Utility to send a USB port reset to a USB device
- MAINTAINER:=Jo-Philipp Wich <xm@subsignal.org>
-endef
-
-define Package/usbreset/description
- This package contains the small usbreset utility which
- can be used to send a USB port reset to a USB device -
- useful for debugging or to force re-detection of particular
- devices.
-endef
-
-define Build/Prepare
- $(INSTALL_DIR) $(PKG_BUILD_DIR)
- $(INSTALL_DATA) ./src/usbreset.c $(PKG_BUILD_DIR)/
-endef
-
-define Build/Compile
- $(TARGET_CC) $(TARGET_CFLAGS) -Wall \
- -o $(PKG_BUILD_DIR)/usbreset $(PKG_BUILD_DIR)/usbreset.c
-endef
-
-define Package/usbreset/install
- $(INSTALL_DIR) $(1)/usr/bin
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/usbreset $(1)/usr/bin/
-endef
-
-$(eval $(call BuildPackage,usbreset))