aboutsummaryrefslogtreecommitdiffstats
path: root/package/usbreset/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2011-12-25 13:59:17 +0000
committerJo-Philipp Wich <jow@openwrt.org>2011-12-25 13:59:17 +0000
commit250ef0cb72325e88afa6dfc95f6d9477c62ca1b3 (patch)
tree3c9a33f4b071ab6012f131d62a798549cfd93638 /package/usbreset/Makefile
parent9fa33ceee2e7831dcfc6391b0e9d7b7117c6ef92 (diff)
downloadupstream-250ef0cb72325e88afa6dfc95f6d9477c62ca1b3.tar.gz
upstream-250ef0cb72325e88afa6dfc95f6d9477c62ca1b3.tar.bz2
upstream-250ef0cb72325e88afa6dfc95f6d9477c62ca1b3.zip
add usbreset - a small simple utility to send port rests to selected usb devices (#10394)
SVN-Revision: 29611
Diffstat (limited to 'package/usbreset/Makefile')
-rw-r--r--package/usbreset/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/package/usbreset/Makefile b/package/usbreset/Makefile
new file mode 100644
index 0000000000..32e073faaf
--- /dev/null
+++ b/package/usbreset/Makefile
@@ -0,0 +1,44 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=usbreset
+PKG_RELEASE:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/usbreset
+ SECTION:=utils
+ CATEGORY:=Utilities
+ TITLE:=Utility to send a USB port reset to a USB device
+ MAINTAINER:=Jo-Philipp Wich <xm@subsignal.org>
+endef
+
+define Package/usbreset/description
+ This package contains the small usbreset utility which
+ can be used to send a USB port reset to a USB device -
+ useful for debugging or to force re-detection of particular
+ devices.
+endef
+
+define Build/Prepare
+ $(INSTALL_DIR) $(PKG_BUILD_DIR)
+ $(INSTALL_DATA) ./src/usbreset.c $(PKG_BUILD_DIR)/
+endef
+
+define Build/Compile
+ $(TARGET_CC) $(TARGET_CFLAGS) -Wall \
+ -o $(PKG_BUILD_DIR)/usbreset $(PKG_BUILD_DIR)/usbreset.c
+endef
+
+define Package/usbreset/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/usbreset $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,usbreset))