aboutsummaryrefslogtreecommitdiffstats
path: root/package/unvram/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-04-27 15:44:07 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-04-27 15:44:07 +0000
commitc2696fb7067d5646e0c6566f00d10b7a4dc856af (patch)
tree285477c4a1d9ae3c6315d90eb503b5475357cd0e /package/unvram/Makefile
parent7fc886584f3e9ee1ac74897a49e817ce00bdc1bf (diff)
downloadupstream-c2696fb7067d5646e0c6566f00d10b7a4dc856af.tar.gz
upstream-c2696fb7067d5646e0c6566f00d10b7a4dc856af.tar.bz2
upstream-c2696fb7067d5646e0c6566f00d10b7a4dc856af.zip
remove leftover unvram directory and move the nvram.init change to package/nvram
SVN-Revision: 15447
Diffstat (limited to 'package/unvram/Makefile')
-rw-r--r--package/unvram/Makefile53
1 files changed, 0 insertions, 53 deletions
diff --git a/package/unvram/Makefile b/package/unvram/Makefile
deleted file mode 100644
index fa8f661756..0000000000
--- a/package/unvram/Makefile
+++ /dev/null
@@ -1,53 +0,0 @@
-#
-# Copyright (C) 2009 Jo-Philipp Wich <xm@subsignal.org>
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=unvram
-PKG_RELEASE:=4
-
-PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/unvram
- SECTION:=utils
- CATEGORY:=Base system
- TITLE:=Userspace port of the Broadcom NVRAM manipulation tool
- DEPENDS:=@TARGET_brcm_2_4||@TARGET_brcm47xx
-endef
-
-define Package/unvram/description
- This package contains an utility to manipulate NVRAM on Broadcom based devices.
- It works on both brcm-2.4 and bcm47xx (Linux 2.6) without using the kernel api.
-endef
-
-define Build/Prepare
- mkdir -p $(PKG_BUILD_DIR)
- $(CP) ./src/* $(PKG_BUILD_DIR)/
-endef
-
-define Build/Configure
-endef
-
-define Build/Compile
- $(MAKE) -C $(PKG_BUILD_DIR) \
- CC="$(TARGET_CC)" \
- CFLAGS="$(TARGET_CFLAGS) -Wall" \
- LDFLAGS="$(TARGET_LDFLAGS)"
-endef
-
-define Package/unvram/install
- $(INSTALL_DIR) $(1)/etc/init.d
- $(INSTALL_BIN) ./files/nvram.init $(1)/etc/init.d/nvram
- $(INSTALL_DIR) $(1)/usr/sbin
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/nvram $(1)/usr/sbin/
- $(INSTALL_DIR) $(1)/usr/lib
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/libnvram.so.0.1 $(1)/usr/lib/
-endef
-
-$(eval $(call BuildPackage,unvram))