aboutsummaryrefslogtreecommitdiffstats
path: root/package/uhttpd
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-06-02 14:56:24 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-06-02 14:56:24 +0000
commit4c82a595155b1758b7ddcc512e06f32e7641340e (patch)
tree8a89e27cddbc2918d3473c665190d36e748bbb22 /package/uhttpd
parent8cf477bc739cd347279d7ae547271c91879c9869 (diff)
downloadupstream-4c82a595155b1758b7ddcc512e06f32e7641340e.tar.gz
upstream-4c82a595155b1758b7ddcc512e06f32e7641340e.tar.bz2
upstream-4c82a595155b1758b7ddcc512e06f32e7641340e.zip
[package] uhttpd: add explicit stdin eof notification for Lua and CGI childs
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32027 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/uhttpd')
-rw-r--r--package/uhttpd/Makefile2
-rw-r--r--package/uhttpd/src/uhttpd-cgi.c4
-rw-r--r--package/uhttpd/src/uhttpd-lua.c6
3 files changed, 10 insertions, 2 deletions
diff --git a/package/uhttpd/Makefile b/package/uhttpd/Makefile
index 13da14dfe9..9d8f9fa95d 100644
--- a/package/uhttpd/Makefile
+++ b/package/uhttpd/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=uhttpd
-PKG_RELEASE:=34
+PKG_RELEASE:=35
PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
PKG_CONFIG_DEPENDS := \
diff --git a/package/uhttpd/src/uhttpd-cgi.c b/package/uhttpd/src/uhttpd-cgi.c
index 2f7ea7afaa..5e445ca372 100644
--- a/package/uhttpd/src/uhttpd-cgi.c
+++ b/package/uhttpd/src/uhttpd-cgi.c
@@ -181,6 +181,10 @@ static bool uh_cgi_socket_cb(struct client *cl)
/* ... write to CGI process */
len = uh_raw_send(state->wfd, buf, len,
cl->server->conf->script_timeout);
+
+ /* explicit EOF notification for the child */
+ if (state->content_length <= 0)
+ close(state->wfd);
}
/* try to read data from child */
diff --git a/package/uhttpd/src/uhttpd-lua.c b/package/uhttpd/src/uhttpd-lua.c
index 7d602f7c58..e8d932b47b 100644
--- a/package/uhttpd/src/uhttpd-lua.c
+++ b/package/uhttpd/src/uhttpd-lua.c
@@ -298,9 +298,13 @@ static bool uh_lua_socket_cb(struct client *cl)
else
state->content_length = 0;
- /* ... write to CGI process */
+ /* ... write to Lua process */
len = uh_raw_send(state->wfd, buf, len,
cl->server->conf->script_timeout);
+
+ /* explicit EOF notification for the child */
+ if (state->content_length <= 0)
+ close(state->wfd);
}
/* try to read data from child */