aboutsummaryrefslogtreecommitdiffstats
path: root/package/uhttpd
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-11-10 20:52:30 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-11-10 20:52:30 +0000
commit1cdac6bf95aa2bd88a960141ad38a4a4b5cde9f9 (patch)
tree48388c5d19c5e03718b3f0535553d14b99e1d413 /package/uhttpd
parent117b47080501652dbb5f5f371b23931469b843b2 (diff)
downloadupstream-1cdac6bf95aa2bd88a960141ad38a4a4b5cde9f9.tar.gz
upstream-1cdac6bf95aa2bd88a960141ad38a4a4b5cde9f9.tar.bz2
upstream-1cdac6bf95aa2bd88a960141ad38a4a4b5cde9f9.zip
[package] uhttpd: redirect to same location with trailing slash appended if directories are requested
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@23952 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/uhttpd')
-rw-r--r--package/uhttpd/Makefile2
-rw-r--r--package/uhttpd/src/uhttpd-utils.c21
-rw-r--r--package/uhttpd/src/uhttpd-utils.h1
-rw-r--r--package/uhttpd/src/uhttpd.c3
4 files changed, 22 insertions, 5 deletions
diff --git a/package/uhttpd/Makefile b/package/uhttpd/Makefile
index 29d3ee5b1f..b639c007b2 100644
--- a/package/uhttpd/Makefile
+++ b/package/uhttpd/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=uhttpd
-PKG_RELEASE:=18
+PKG_RELEASE:=19
PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
PKG_BUILD_DEPENDS := libcyassl liblua
diff --git a/package/uhttpd/src/uhttpd-utils.c b/package/uhttpd/src/uhttpd-utils.c
index 9f9a5dd6a7..c7bc867aab 100644
--- a/package/uhttpd/src/uhttpd-utils.c
+++ b/package/uhttpd/src/uhttpd-utils.c
@@ -474,6 +474,7 @@ struct path_info * uh_path_lookup(struct client *cl, const char *url)
char *docroot = cl->server->conf->docroot;
char *pathptr = NULL;
+ int slash = 0;
int no_sym = cl->server->conf->no_symlinks;
int i = 0;
struct stat s;
@@ -516,7 +517,7 @@ struct path_info * uh_path_lookup(struct client *cl, const char *url)
}
/* create canon path */
- for( i = strlen(buffer); i >= 0; i-- )
+ for( i = strlen(buffer), slash = (buffer[max(0, i-1)] == '/'); i >= 0; i-- )
{
if( (buffer[i] == 0) || (buffer[i] == '/') )
{
@@ -567,7 +568,23 @@ struct path_info * uh_path_lookup(struct client *cl, const char *url)
memcpy(buffer, path_phys, sizeof(buffer));
pathptr = &buffer[strlen(buffer)];
- if( cl->server->conf->index_file )
+ /* if requested url resolves to a directory and a trailing slash
+ is missing in the request url, redirect the client to the same
+ url with trailing slash appended */
+ if( !slash )
+ {
+ uh_http_sendf(cl, NULL,
+ "HTTP/1.1 302 Found\r\n"
+ "Location: %s%s%s\r\n"
+ "Connection: close\r\n\r\n",
+ &path_phys[strlen(docroot)],
+ p.query ? "?" : "",
+ p.query ? p.query : ""
+ );
+
+ p.redirected = 1;
+ }
+ else if( cl->server->conf->index_file )
{
strncat(buffer, cl->server->conf->index_file, sizeof(buffer));
diff --git a/package/uhttpd/src/uhttpd-utils.h b/package/uhttpd/src/uhttpd-utils.h
index 6a0a395a91..769e5b45d6 100644
--- a/package/uhttpd/src/uhttpd-utils.h
+++ b/package/uhttpd/src/uhttpd-utils.h
@@ -52,6 +52,7 @@ struct path_info {
char *name;
char *info;
char *query;
+ int redirected;
struct stat stat;
};
diff --git a/package/uhttpd/src/uhttpd.c b/package/uhttpd/src/uhttpd.c
index a818e1c450..491452b634 100644
--- a/package/uhttpd/src/uhttpd.c
+++ b/package/uhttpd/src/uhttpd.c
@@ -566,7 +566,7 @@ static void uh_mainloop(struct config *conf, fd_set serv_fds, int max_fd)
if( (pin = uh_path_lookup(cl, req->url)) != NULL )
{
/* auth ok? */
- if( uh_auth_check(cl, req, pin) )
+ if( !pin->redirected && uh_auth_check(cl, req, pin) )
uh_dispatch_request(cl, req, pin);
}
@@ -1089,4 +1089,3 @@ int main (int argc, char **argv)
return 0;
}
-