aboutsummaryrefslogtreecommitdiffstats
path: root/package/udev
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-05-11 16:00:43 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-05-11 16:00:43 +0000
commitb97ca641b4aa79ecee3e632758d2e84d5d365282 (patch)
tree77d5a5642e464a762bd56646a801836158df05ef /package/udev
parent8b7d9fc053b56827d196da7d2dced619a9d6504d (diff)
downloadupstream-b97ca641b4aa79ecee3e632758d2e84d5d365282.tar.gz
upstream-b97ca641b4aa79ecee3e632758d2e84d5d365282.tar.bz2
upstream-b97ca641b4aa79ecee3e632758d2e84d5d365282.zip
replace $(IDIR_*) with $(1)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@3759 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/udev')
-rw-r--r--package/udev/Makefile28
1 files changed, 14 insertions, 14 deletions
diff --git a/package/udev/Makefile b/package/udev/Makefile
index 9b7c9171ae..620aa1aedd 100644
--- a/package/udev/Makefile
+++ b/package/udev/Makefile
@@ -31,20 +31,20 @@ URL:=http://www.kernel.org/pub/linux/utils/kernel/hotplug/udev.html
endef
define Package/udev/install
- install -d -m0775 $(IDIR_UDEV)/etc/udev
- install -d -m0775 $(IDIR_UDEV)/lib/udev
- install -d -m0775 $(IDIR_UDEV)/sbin/
- install -d -m0775 $(IDIR_UDEV)/usr/bin/
- install -d -m0775 $(IDIR_UDEV)/usr/sbin/
- $(CP) $(PKG_INSTALL_DIR)/etc/udev/* $(IDIR_UDEV)/etc/udev/
- $(CP) $(PKG_INSTALL_DIR)/sbin/udev $(IDIR_UDEV)/sbin/
- $(CP) $(PKG_INSTALL_DIR)/sbin/udevcontrol $(IDIR_UDEV)/sbin/
- $(CP) $(PKG_INSTALL_DIR)/sbin/udevd $(IDIR_UDEV)/sbin/
- $(CP) $(PKG_INSTALL_DIR)/sbin/udevsend $(IDIR_UDEV)/sbin/
- $(CP) $(PKG_INSTALL_DIR)/sbin/udevstart $(IDIR_UDEV)/sbin/
- $(CP) $(PKG_INSTALL_DIR)/usr/bin/udevinfo $(IDIR_UDEV)/usr/bin/
- $(CP) $(PKG_INSTALL_DIR)/usr/bin/udevtest $(IDIR_UDEV)/usr/bin/
- $(CP) $(PKG_INSTALL_DIR)/usr/sbin/udevmonitor $(IDIR_UDEV)/usr/sbin/
+ install -d -m0775 $(1)/etc/udev
+ install -d -m0775 $(1)/lib/udev
+ install -d -m0775 $(1)/sbin/
+ install -d -m0775 $(1)/usr/bin/
+ install -d -m0775 $(1)/usr/sbin/
+ $(CP) $(PKG_INSTALL_DIR)/etc/udev/* $(1)/etc/udev/
+ $(CP) $(PKG_INSTALL_DIR)/sbin/udev $(1)/sbin/
+ $(CP) $(PKG_INSTALL_DIR)/sbin/udevcontrol $(1)/sbin/
+ $(CP) $(PKG_INSTALL_DIR)/sbin/udevd $(1)/sbin/
+ $(CP) $(PKG_INSTALL_DIR)/sbin/udevsend $(1)/sbin/
+ $(CP) $(PKG_INSTALL_DIR)/sbin/udevstart $(1)/sbin/
+ $(CP) $(PKG_INSTALL_DIR)/usr/bin/udevinfo $(1)/usr/bin/
+ $(CP) $(PKG_INSTALL_DIR)/usr/bin/udevtest $(1)/usr/bin/
+ $(CP) $(PKG_INSTALL_DIR)/usr/sbin/udevmonitor $(1)/usr/sbin/
endef
$(eval $(call BuildPackage,udev))