aboutsummaryrefslogtreecommitdiffstats
path: root/package/udev
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-10-23 06:23:36 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-10-23 06:23:36 +0000
commit3aade25a90245511c0b5f0ad7278a1977e248a4c (patch)
treefb18971863f8497029305b351a435c84d2c01825 /package/udev
parent00b56dd8e23d654939ea37af86f7c0e7e201a2e1 (diff)
downloadupstream-3aade25a90245511c0b5f0ad7278a1977e248a4c.tar.gz
upstream-3aade25a90245511c0b5f0ad7278a1977e248a4c.tar.bz2
upstream-3aade25a90245511c0b5f0ad7278a1977e248a4c.zip
Add udev initilisation
We have a udev package, but no means to start udev at boot. This change adds the necessary startup in /init, and adds the required /sbin/udevsettle to the udev installed files Signed-off-by: Jeremy Kerr <jk@ozlabs.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9412 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/udev')
-rw-r--r--package/udev/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/udev/Makefile b/package/udev/Makefile
index 0ab8ec83d0..bde7a61e3d 100644
--- a/package/udev/Makefile
+++ b/package/udev/Makefile
@@ -54,6 +54,7 @@ define Package/udev/install
install -d -m0775 $(1)/sbin/
$(CP) $(PKG_INSTALL_DIR)/sbin/udevcontrol $(1)/sbin/
$(CP) $(PKG_INSTALL_DIR)/sbin/udevd $(1)/sbin/
+ $(CP) $(PKG_INSTALL_DIR)/sbin/udevsettle $(1)/sbin/
install -d -m0775 $(1)/usr/bin/
$(CP) $(PKG_INSTALL_DIR)/usr/bin/udevinfo $(1)/usr/bin/
$(CP) $(PKG_INSTALL_DIR)/usr/bin/udevtest $(1)/usr/bin/