aboutsummaryrefslogtreecommitdiffstats
path: root/package/udev/Makefile
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2006-11-24 16:25:11 +0000
committerImre Kaloz <kaloz@openwrt.org>2006-11-24 16:25:11 +0000
commitd5212134de3f04fdeed89a3cbf37bc244932d18b (patch)
tree38ecb898ebf6e2d907e06b8ca0605e69e16a0991 /package/udev/Makefile
parent1df3de900cb4bc97bc629793986f495b3c95bb9d (diff)
downloadupstream-d5212134de3f04fdeed89a3cbf37bc244932d18b.tar.gz
upstream-d5212134de3f04fdeed89a3cbf37bc244932d18b.tar.bz2
upstream-d5212134de3f04fdeed89a3cbf37bc244932d18b.zip
upgrade udev to v103, add kexec-tools
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5637 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/udev/Makefile')
-rw-r--r--package/udev/Makefile9
1 files changed, 3 insertions, 6 deletions
diff --git a/package/udev/Makefile b/package/udev/Makefile
index 830ea6a664..2f91c052fb 100644
--- a/package/udev/Makefile
+++ b/package/udev/Makefile
@@ -9,7 +9,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=udev
-PKG_VERSION:=077
+PKG_VERSION:=103
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -19,7 +19,7 @@ PKG_SOURCE_URL:=ftp://ftp.kernel.org/pub/linux/utils/kernel/hotplug/ \
http://ftp.de.kernel.org/pub/linux/utils/kernel/hotplug/ \
ftp://ftp.fr.kernel.org/pub/linux/utils/kernel/hotplug/ \
http://ftp.fr.kernel.org/pub/linux/utils/kernel/hotplug/
-PKG_MD5SUM:=61ec646daf7795e9777e8f33975408fe
+PKG_MD5SUM:=7360ce47b5ec3f9fa71f18071ecb8b97
PKG_CAT:=bzcat
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
@@ -41,7 +41,7 @@ endef
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
- CROSS="$(TARGET_CROSS)" \
+ CROSS_COMPILE="$(TARGET_CROSS)" \
STRIP="/bin/true" \
OPTFLAGS="$(TARGET_CFLAGS)" \
DESTDIR="$(PKG_INSTALL_DIR)" \
@@ -54,11 +54,8 @@ define Package/udev/install
$(CP) $(PKG_INSTALL_DIR)/etc/udev/* $(1)/etc/udev/
install -d -m0775 $(1)/lib/udev
install -d -m0775 $(1)/sbin/
- $(CP) $(PKG_INSTALL_DIR)/sbin/udev $(1)/sbin/
$(CP) $(PKG_INSTALL_DIR)/sbin/udevcontrol $(1)/sbin/
$(CP) $(PKG_INSTALL_DIR)/sbin/udevd $(1)/sbin/
- $(CP) $(PKG_INSTALL_DIR)/sbin/udevsend $(1)/sbin/
- $(CP) $(PKG_INSTALL_DIR)/sbin/udevstart $(1)/sbin/
install -d -m0775 $(1)/usr/bin/
$(CP) $(PKG_INSTALL_DIR)/usr/bin/udevinfo $(1)/usr/bin/
$(CP) $(PKG_INSTALL_DIR)/usr/bin/udevtest $(1)/usr/bin/