aboutsummaryrefslogtreecommitdiffstats
path: root/package/uci
diff options
context:
space:
mode:
authorAndy Boyett <agb@openwrt.org>2008-04-04 21:48:43 +0000
committerAndy Boyett <agb@openwrt.org>2008-04-04 21:48:43 +0000
commit24c9bbe5f779d6685a21a9de51924cc1dac3fc96 (patch)
treed42859725946e1ff3a5c47010769e638924b9d79 /package/uci
parent16f1b84a590fab89ef8fc1227f9188edb5416882 (diff)
downloadupstream-24c9bbe5f779d6685a21a9de51924cc1dac3fc96.tar.gz
upstream-24c9bbe5f779d6685a21a9de51924cc1dac3fc96.tar.bz2
upstream-24c9bbe5f779d6685a21a9de51924cc1dac3fc96.zip
Install libuci and headers in staging_dir
SVN-Revision: 10732
Diffstat (limited to 'package/uci')
-rw-r--r--package/uci/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/package/uci/Makefile b/package/uci/Makefile
index 54d01c1589..41430f7e14 100644
--- a/package/uci/Makefile
+++ b/package/uci/Makefile
@@ -1,4 +1,4 @@
-#
+#
# Copyright (C) 2008 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
@@ -73,6 +73,13 @@ define Package/uci-sh/install
$(CP) ./files/uci-sh/* $(1)/
endef
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include
+ $(CP) $(PKG_BUILD_DIR)/uci{,_config}.h $(1)/usr/include
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_BUILD_DIR)/libuci.so* $(1)/usr/lib
+endef
+
$(eval $(call BuildPackage,uci))
$(eval $(call BuildPackage,libuci))
$(eval $(call BuildPackage,uci-sh))