aboutsummaryrefslogtreecommitdiffstats
path: root/package/uci/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-10-20 08:26:39 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-10-20 08:26:39 +0000
commite218149d728e670cd780d262f6e3f09e8d5e097f (patch)
treecbc956852c622eef988754887285e8c6b0fd7b33 /package/uci/Makefile
parent0ee55d9f550693ab256403115b03dc521a605cd0 (diff)
downloadupstream-e218149d728e670cd780d262f6e3f09e8d5e097f.tar.gz
upstream-e218149d728e670cd780d262f6e3f09e8d5e097f.tar.bz2
upstream-e218149d728e670cd780d262f6e3f09e8d5e097f.zip
uci: only use $(FPIC) on library parts, saves a few hundred bytes
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18092 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/uci/Makefile')
-rw-r--r--package/uci/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/uci/Makefile b/package/uci/Makefile
index e5e5231a55..b86a4fea16 100644
--- a/package/uci/Makefile
+++ b/package/uci/Makefile
@@ -53,13 +53,13 @@ endef
define Build/Configure
endef
-TARGET_CFLAGS += $(FPIC)
UCI_MAKEOPTS = \
$(TARGET_CONFIGURE_OPTS) \
COPTS="$(TARGET_CFLAGS)" \
DEBUG="$(DEBUG)" \
VERSION="$(UCI_VERSION)" \
CPPFLAGS="-I$(PKG_BUILD_DIR) $(TARGET_CPPFLAGS)" \
+ FPIC="$(FPIC)" \
OS="Linux"
# work around a nasty gcc bug