aboutsummaryrefslogtreecommitdiffstats
path: root/package/uboot-xburst/files/board/nanonote/Makefile
diff options
context:
space:
mode:
authorLars-Peter Clausen <lars@metafoo.de>2010-04-12 18:17:26 +0000
committerLars-Peter Clausen <lars@metafoo.de>2010-04-12 18:17:26 +0000
commit9f68544705ed91439cb1104ef3e17b0f4a9f7853 (patch)
tree507db9e61d7632c134b60a5f8b53d266f2bd1254 /package/uboot-xburst/files/board/nanonote/Makefile
parentf46b3d70d30353c8d3d782dd1814028077edf96e (diff)
downloadupstream-9f68544705ed91439cb1104ef3e17b0f4a9f7853.tar.gz
upstream-9f68544705ed91439cb1104ef3e17b0f4a9f7853.tar.bz2
upstream-9f68544705ed91439cb1104ef3e17b0f4a9f7853.zip
[package] Add uboot for xburst package
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20832 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/uboot-xburst/files/board/nanonote/Makefile')
-rw-r--r--package/uboot-xburst/files/board/nanonote/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/package/uboot-xburst/files/board/nanonote/Makefile b/package/uboot-xburst/files/board/nanonote/Makefile
new file mode 100644
index 0000000000..2c726a788b
--- /dev/null
+++ b/package/uboot-xburst/files/board/nanonote/Makefile
@@ -0,0 +1,38 @@
+#
+# (C) Copyright 2006
+# Ingenic Semiconductor, <jlwei@ingenic.cn>
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2 of
+# the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston,
+# MA 02111-1307 USA
+#
+
+include $(TOPDIR)/config.mk
+
+LIB = lib$(BOARD).a
+
+OBJS = $(BOARD).o
+SOBJS =
+
+$(LIB): .depend $(OBJS) $(SOBJS)
+ $(AR) crv $@ $(OBJS) $(SOBJS)
+
+#########################################################################
+
+.depend: Makefile $(SOBJS:.o=.S) $(OBJS:.o=.c)
+ $(CC) -M $(CFLAGS) $(SOBJS:.o=.S) $(OBJS:.o=.c) > $@
+
+sinclude .depend
+
+#########################################################################