aboutsummaryrefslogtreecommitdiffstats
path: root/package/uboot-pxa/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2012-10-16 13:44:25 +0000
committerJohn Crispin <blogic@openwrt.org>2012-10-16 13:44:25 +0000
commita7fb4200cccec4f1e521b803044714901f7bc410 (patch)
tree5937de88cb9dca7bfebc4dc3dce3cf904bf65357 /package/uboot-pxa/Makefile
parente910e78dba966a90ce42a39c7496c279b9d915cc (diff)
downloadupstream-a7fb4200cccec4f1e521b803044714901f7bc410.tar.gz
upstream-a7fb4200cccec4f1e521b803044714901f7bc410.tar.bz2
upstream-a7fb4200cccec4f1e521b803044714901f7bc410.zip
[boot] move boot related packages to their own folder
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33781 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/uboot-pxa/Makefile')
-rw-r--r--package/uboot-pxa/Makefile89
1 files changed, 0 insertions, 89 deletions
diff --git a/package/uboot-pxa/Makefile b/package/uboot-pxa/Makefile
deleted file mode 100644
index 7fe747cf0c..0000000000
--- a/package/uboot-pxa/Makefile
+++ /dev/null
@@ -1,89 +0,0 @@
-#
-# Copyright (C) 2012 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/kernel.mk
-
-PKG_NAME:=u-boot
-PKG_VERSION:=2011.08.25
-PKG_RELEASE:=1
-
-PKG_SOURCE_PROTO:=git
-PKG_SOURCE_URL:=git://github.com/ashcharles/verdex-uboot.git
-PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=ca6bf3ef6ac5f5132a359b43dfa31e07076b74b7
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
-
-include $(INCLUDE_DIR)/package.mk
-
-define uboot/Default
- TITLE:=
- CONFIG:=
- IMAGE:=
-endef
-
-define uboot/gumstix
- TITLE:=U-Boot for the Gumstix Verdex
-endef
-
-UBOOTS:=gumstix
-
-define Package/uboot/template
-define Package/uboot-pxa-$(1)
- SECTION:=boot
- CATEGORY:=Boot Loaders
- DEPENDS:=@TARGET_pxa
- TITLE:=$(2)
- URL:=http://www.denx.de/wiki/U-Boot
- VARIANT:=$(1)
- MAINTAINER:=Florian Fainelli <florian@openwrt.org>
-endef
-endef
-
-define BuildUBootPackage
- $(eval $(uboot/Default))
- $(eval $(uboot/$(1)))
- $(call Package/uboot/template,$(1),$(TITLE))
-endef
-
-ifdef BUILD_VARIANT
-$(eval $(call uboot/$(BUILD_VARIANT)))
-UBOOT_CONFIG:=$(if $(CONFIG),$(CONFIG),$(BUILD_VARIANT))
-UBOOT_IMAGE:=$(if $(IMAGE),$(IMAGE),openwrt-$(BOARD)-$(BUILD_VARIANT)-u-boot.bin)
-endif
-
-define Build/Configure
- $(MAKE) -C $(PKG_BUILD_DIR) \
- $(UBOOT_CONFIG)_config
-endef
-
-define Build/Compile
- $(MAKE) -C $(PKG_BUILD_DIR) \
- u-boot.bin \
- CROSS_COMPILE=$(TARGET_CROSS)
-endef
-
-define Package/uboot/install/default
- $(INSTALL_DIR) $(BIN_DIR)
- $(CP) $(PKG_BUILD_DIR)/u-boot.bin \
- $(BIN_DIR)/openwrt-$(BOARD)-$(1)-u-boot.bin
-endef
-
-define Package/uboot/install/template
-define Package/uboot-pxa-$(1)/install
- $(call Package/uboot/install/default,$(2))
-endef
-endef
-
-$(foreach u,$(UBOOTS), \
- $(eval $(call Package/uboot/install/template,$(u),$(u))) \
-)
-
-$(foreach u,$(UBOOTS), \
- $(eval $(call BuildUBootPackage,$(u))) \
- $(eval $(call BuildPackage,uboot-pxa-$(u))) \
-)