aboutsummaryrefslogtreecommitdiffstats
path: root/package/uboot-lantiq
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2011-03-11 08:22:47 +0000
committerJohn Crispin <blogic@openwrt.org>2011-03-11 08:22:47 +0000
commit858b69220ae9c509da3c338cb9cd8607032c4955 (patch)
tree2d0cb0783b5bd776e37f03a0377621562f7ffc65 /package/uboot-lantiq
parentb1c9073afcacc417a41ba12f5bd57ee0075a5b98 (diff)
downloadupstream-858b69220ae9c509da3c338cb9cd8607032c4955.tar.gz
upstream-858b69220ae9c509da3c338cb9cd8607032c4955.tar.bz2
upstream-858b69220ae9c509da3c338cb9cd8607032c4955.zip
[uboot-lantiq]
* add some compile flags git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26025 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/uboot-lantiq')
-rw-r--r--package/uboot-lantiq/patches/010-fix-mips-flags.patch6
1 files changed, 4 insertions, 2 deletions
diff --git a/package/uboot-lantiq/patches/010-fix-mips-flags.patch b/package/uboot-lantiq/patches/010-fix-mips-flags.patch
index 4c706a7843..6dd7d8f569 100644
--- a/package/uboot-lantiq/patches/010-fix-mips-flags.patch
+++ b/package/uboot-lantiq/patches/010-fix-mips-flags.patch
@@ -1,6 +1,6 @@
--- a/cpu/mips/config.mk
+++ b/cpu/mips/config.mk
-@@ -23,16 +23,18 @@
+@@ -23,17 +23,19 @@
v=$(shell $(AS) --version | grep 'GNU assembler' | egrep -o '2\.[0-9\.]+' | cut -d. -f2)
MIPSFLAGS:=$(shell \
if [ "$v" -lt "14" ]; then \
@@ -19,5 +19,7 @@
endif
+endif
- MIPSFLAGS += $(ENDIANNESS)
+-MIPSFLAGS += $(ENDIANNESS)
++MIPSFLAGS += $(ENDIANNESS) -fno-schedule-insns -fno-schedule-insns2
+ PLATFORM_CPPFLAGS += $(MIPSFLAGS)