aboutsummaryrefslogtreecommitdiffstats
path: root/package/uboot-lantiq
diff options
context:
space:
mode:
authorRalph Hempel <ralph.hempel@lantiq.com>2010-03-31 09:45:09 +0000
committerRalph Hempel <ralph.hempel@lantiq.com>2010-03-31 09:45:09 +0000
commite43df1aeba1a9ac41d0208948a86c2dd180bac9b (patch)
treec308608693784d978882433a2b6dd97f1c668db6 /package/uboot-lantiq
parent0b03ed8938ebfa7c0ab0d0cd014e088cb25a9776 (diff)
downloadupstream-e43df1aeba1a9ac41d0208948a86c2dd180bac9b.tar.gz
upstream-e43df1aeba1a9ac41d0208948a86c2dd180bac9b.tar.bz2
upstream-e43df1aeba1a9ac41d0208948a86c2dd180bac9b.zip
[uboot-lantiq] cleanup configuration handling
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20628 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/uboot-lantiq')
-rw-r--r--package/uboot-lantiq/Config.in55
-rw-r--r--package/uboot-lantiq/Makefile34
2 files changed, 47 insertions, 42 deletions
diff --git a/package/uboot-lantiq/Config.in b/package/uboot-lantiq/Config.in
index 7544e711df..e2c156d884 100644
--- a/package/uboot-lantiq/Config.in
+++ b/package/uboot-lantiq/Config.in
@@ -1,32 +1,35 @@
-config UBOOT_CONFIG
- string "configuration file"
- default "easy50712_DDR166M"
- help
- The configuration reflects the settings for a dedicated board hardware.
- Select for Danube evaluation board easy50712_DDR166M .
- Select for AR9 evaluation board easy50812_DDR166M .
-
-config UBOOT_DDR_CONFIG
- string "DDR configuration file"
- default "danube_ref_ddr166.conf"
- depends on UBOOT_RAMBOOT
- help
- The DDR configuration file should reflect the DDR memory device configuration .
- It will be used to create a RAM boot image
- Select for Danube evalution board danube_ref_ddr166.conf .
- Select for AR9 evalution board easy50812.conf .
+config UBOOT_TARGET
+ string "target"
+ default "easy50712_DDR166M"
+ depends on PACKAGE_uboot-lantiq
+ help
+ The configuration reflects the settings for a dedicated board hardware.
+ Select for Danube evaluation board easy50712_DDR166M .
+ Select for AR9 evaluation board easy50812_DDR166M .
config UBOOT_RAMBOOT
- bool "Enable RAM boot image"
- help
- Using the UART boot mode of the ROM code this image could be loaded to the RAM.
- Executing the image in the RAM the functionality of the uboot image can be
- tested first without touching the original flash.
- Note: Be carefull, by saving the environment the flash will be modified.
- The OWRT flash layout differs from the layout provided by Lantiq / Infineon.
+ bool "Enable RAM boot image"
+ depends on PACKAGE_uboot-lantiq
+ help
+ Using the UART boot mode of the ROM code this image could be loaded to the RAM.
+ While executing the image in the RAM the functionality of the uboot image can be
+ tested first without touching the original flash.
+ Note: Be carefull, by saving the environment the flash will be modified.
+ The OWRT flash layout differs from the layout provided by Lantiq / Infineon.
+
+config UBOOT_RAMBOOT_DDR_CONFIG
+ string "DDR configuration file"
+ default "easy50712_DDR166M.conf"
+ depends on UBOOT_RAMBOOT
+ help
+ The DDR configuration file should reflect the DDR memory device configuration .
+ It will be used to create a RAM boot image
+ Select for Danube evalution board easy50712_DDR166M.conf .
+ Select for AR9 evalution board easy50812.conf .
+
-config IFXMIPS_UBOOT_A800
+config UBOOT_A800
bool "add ARV452 Switch bringup hack"
- depends on PACKAGE_uboot-ifxmips
+ depends on PACKAGE_uboot-lantiq
help
Say Y, if you have a arv452 board (wav-281, A800, ..)
diff --git a/package/uboot-lantiq/Makefile b/package/uboot-lantiq/Makefile
index 985f3638ae..fc7c653716 100644
--- a/package/uboot-lantiq/Makefile
+++ b/package/uboot-lantiq/Makefile
@@ -20,6 +20,10 @@ PKG_TARGETS:=bin
include $(INCLUDE_DIR)/package.mk
+ifeq ($(DUMP),)
+ STAMP_CONFIGURED:=$(strip $(STAMP_CONFIGURED))_$(shell grep '^CONFIG_UBOOT_' $(TOPDIR)/.config | md5s)
+endif
+
define Package/uboot-lantiq
SECTION:=boot
CATEGORY:=Boot Loaders
@@ -35,8 +39,8 @@ define Build/Prepare
find $(PKG_BUILD_DIR) -name .svn | $(XARGS) rm -rf
endef
-UBOOT_CONFIG:=$(call qstrip,$(CONFIG_UBOOT_CONFIG))
-UBOOT_DDR_CONFIG:=$(call qstrip,$(CONFIG_UBOOT_DDR_CONFIG))
+UBOOT_TARGET:=$(call qstrip,$(CONFIG_UBOOT_TARGET))
+UBOOT_RAMBOOT_DDR_CONFIG:=$(call qstrip,$(CONFIG_UBOOT_RAMBOOT_DDR_CONFIG))
UBOOT_MAKE_OPTS:= \
CROSS_COMPILE=$(TARGET_CROSS) \
@@ -44,9 +48,7 @@ UBOOT_MAKE_OPTS:= \
V=1
define Package/uboot-lantiq/config
- menu "configuration"
- source "$(SOURCE)/Config.in"
- endmenu
+ source "$(SOURCE)/Config.in"
endef
define Build/Configure/Target
@@ -57,9 +59,9 @@ define Build/Configure/Target
endef
define Build/Configure
- $(call Build/Configure/Target,$(UBOOT_CONFIG))
+ $(call Build/Configure/Target,$(UBOOT_TARGET))
ifeq ($(CONFIG_UBOOT_RAMBOOT),y)
- $(call Build/Configure/Target,$(UBOOT_CONFIG)_ramboot)
+ $(call Build/Configure/Target,$(UBOOT_TARGET)_ramboot)
endif
endef
@@ -71,24 +73,24 @@ define Build/Compile/Target
endef
define Build/Compile
- $(call Build/Compile/Target,$(UBOOT_CONFIG))
+ $(call Build/Compile/Target,$(UBOOT_TARGET))
ifeq ($(CONFIG_UBOOT_RAMBOOT),y)
- $(call Build/Compile/Target,$(UBOOT_CONFIG)_ramboot)
+ $(call Build/Compile/Target,$(UBOOT_TARGET)_ramboot)
endif
endef
define Package/uboot-lantiq/install
- mkdir -p $(1)/$(UBOOT_CONFIG)
+ mkdir -p $(1)/$(UBOOT_TARGET)
dd \
- if=$(PKG_BUILD_DIR)/$(UBOOT_CONFIG)/u-boot.bin \
- of=$(1)/$(UBOOT_CONFIG)/u-boot.bin \
+ if=$(PKG_BUILD_DIR)/$(UBOOT_TARGET)/u-boot.bin \
+ of=$(1)/$(UBOOT_TARGET)/u-boot.bin \
bs=64k conv=sync
ifeq ($(CONFIG_UBOOT_RAMBOOT),y)
- if [ -e $(UBOOT_DDR_CONFIG) ]; then \
+ if [ -e $(UBOOT_RAMBOOT_DDR_CONFIG) ]; then \
perl ./gct \
- $(UBOOT_DDR_CONFIG) \
- $(PKG_BUILD_DIR)/$(UBOOT_CONFIG)_ramboot/u-boot.srec \
- $(1)/$(UBOOT_CONFIG)/u-boot.asc; \
+ $(UBOOT_RAMBOOT_DDR_CONFIG) \
+ $(PKG_BUILD_DIR)/$(UBOOT_TARGET)_ramboot/u-boot.srec \
+ $(1)/$(UBOOT_TARGET)/u-boot.asc; \
fi
endif
endef