aboutsummaryrefslogtreecommitdiffstats
path: root/package/uboot-lantiq/files/board/infineon/easy50812/Makefile
diff options
context:
space:
mode:
authorRalph Hempel <ralph.hempel@lantiq.com>2010-03-30 13:56:30 +0000
committerRalph Hempel <ralph.hempel@lantiq.com>2010-03-30 13:56:30 +0000
commit046d73d3c2bc3a515024c2cc8339d1177e749b77 (patch)
treee6c0308590b8a125833f31549758973328c4f577 /package/uboot-lantiq/files/board/infineon/easy50812/Makefile
parentaa323e0134c4dd374869446738b701f82d014c89 (diff)
downloadupstream-046d73d3c2bc3a515024c2cc8339d1177e749b77.tar.gz
upstream-046d73d3c2bc3a515024c2cc8339d1177e749b77.tar.bz2
upstream-046d73d3c2bc3a515024c2cc8339d1177e749b77.zip
add preliminary AR9 support attention: if caches enabled the network is broken attention: the network of the flash image doesn't work because of enabled caches
SVN-Revision: 20606
Diffstat (limited to 'package/uboot-lantiq/files/board/infineon/easy50812/Makefile')
-rw-r--r--package/uboot-lantiq/files/board/infineon/easy50812/Makefile47
1 files changed, 47 insertions, 0 deletions
diff --git a/package/uboot-lantiq/files/board/infineon/easy50812/Makefile b/package/uboot-lantiq/files/board/infineon/easy50812/Makefile
new file mode 100644
index 0000000000..44d8ea3443
--- /dev/null
+++ b/package/uboot-lantiq/files/board/infineon/easy50812/Makefile
@@ -0,0 +1,47 @@
+#
+# (C) Copyright 2003-2006
+# Wolfgang Denk, DENX Software Engineering, wd@denx.de.
+#
+# See file CREDITS for list of people who contributed to this
+# project.
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2 of
+# the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston,
+# MA 02111-1307 USA
+#
+
+include $(TOPDIR)/config.mk
+
+LIB = $(obj)lib$(BOARD).a
+
+#COBJS := $(BOARD).o
+COBJS-y += ar9.o
+
+SOBJS = lowlevel_init.o pmuenable.o
+
+SRCS := $(SOBJS:.o=.S) $(COBJS-y:.o=.c)
+OBJS := $(addprefix $(obj),$(COBJS-y))
+SOBJS := $(addprefix $(obj),$(SOBJS))
+
+$(LIB): $(obj).depend $(OBJS) $(SOBJS)
+ $(AR) $(ARFLAGS) $@ $(OBJS) $(SOBJS)
+
+#########################################################################
+
+# defines $(obj).depend target
+include $(SRCTREE)/rules.mk
+
+sinclude $(obj).depend
+
+#########################################################################