aboutsummaryrefslogtreecommitdiffstats
path: root/package/uboot-lantiq/files/board/infineon/easy50712/config.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2011-07-06 10:36:35 +0000
committerJohn Crispin <blogic@openwrt.org>2011-07-06 10:36:35 +0000
commitac64a0094ac5f877795cf6f33ab0a368b4b22f19 (patch)
tree24ac8762654f48f6d62bac5d982c0e47c9097e55 /package/uboot-lantiq/files/board/infineon/easy50712/config.mk
parent6961cda93ae707e9c3a943b0eed69eb0c6cfaf9d (diff)
downloadupstream-ac64a0094ac5f877795cf6f33ab0a368b4b22f19.tar.gz
upstream-ac64a0094ac5f877795cf6f33ab0a368b4b22f19.tar.bz2
upstream-ac64a0094ac5f877795cf6f33ab0a368b4b22f19.zip
fix lantiq uboot to build lzma compressed bootloaders for eval kits
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27487 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/uboot-lantiq/files/board/infineon/easy50712/config.mk')
-rw-r--r--package/uboot-lantiq/files/board/infineon/easy50712/config.mk30
1 files changed, 5 insertions, 25 deletions
diff --git a/package/uboot-lantiq/files/board/infineon/easy50712/config.mk b/package/uboot-lantiq/files/board/infineon/easy50712/config.mk
index c0e5d82445..b110f6f329 100644
--- a/package/uboot-lantiq/files/board/infineon/easy50712/config.mk
+++ b/package/uboot-lantiq/files/board/infineon/easy50712/config.mk
@@ -26,35 +26,15 @@
#
sinclude $(OBJTREE)/board/$(BOARDDIR)/config.tmp
-ifdef CONFIG_LZMA_BOOTSTRAP
-
-ifdef BUILD_BOOTSTRAP
-
-$(info BUILD_BOOTSTRAP )
-#TEXT_BASE = 0xB0000000
-TEXT_BASE = 0x80010000
-
-else # BUILD_BOOTSTRAP
-
-ifndef TEXT_BASE
-$(info redefine TEXT_BASE = 0x80040000 )
-TEXT_BASE = 0x80040000
-endif
-
-endif # BUILD_BOOTSTRAP
-
+ifdef CONFIG_BOOTSTRAP
+TEXT_BASE = 0x80001000
+CONFIG_BOOTSTRAP_TEXT_BASE = 0xb0000000
+CONFIG_SYS_RAMBOOT = y
else
-ifdef BUILD_BOOTSTRAP
-$(error BUILD_BOOTSTRAP but not enabled in config)
-endif
-
ifndef TEXT_BASE
-## Standard: boot from ebu
$(info redefine TEXT_BASE = 0xB0000000 )
TEXT_BASE = 0xB0000000
-## For testing: boot from RAM
-# TEXT_BASE = 0x80100000
endif
-endif # CONFIG_LZMA_BOOTSTRAP
+endif