aboutsummaryrefslogtreecommitdiffstats
path: root/package/uboot-lantiq/files/board/arcadyan/arv4518/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2011-01-23 12:06:02 +0000
committerJohn Crispin <blogic@openwrt.org>2011-01-23 12:06:02 +0000
commit3fa52d588956e1c9d320345d97752847beccb430 (patch)
tree62bb5fa6f0cead9edc7d0a67585b62997328a5d1 /package/uboot-lantiq/files/board/arcadyan/arv4518/Makefile
parent953ddaaba70ea5118b3d7c9d1c8e3862aa03771b (diff)
downloadupstream-3fa52d588956e1c9d320345d97752847beccb430.tar.gz
upstream-3fa52d588956e1c9d320345d97752847beccb430.tar.bz2
upstream-3fa52d588956e1c9d320345d97752847beccb430.zip
[uboot-lantiq] add support for arv4518 and arv752DWP22 boards
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@25071 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/uboot-lantiq/files/board/arcadyan/arv4518/Makefile')
-rw-r--r--package/uboot-lantiq/files/board/arcadyan/arv4518/Makefile47
1 files changed, 47 insertions, 0 deletions
diff --git a/package/uboot-lantiq/files/board/arcadyan/arv4518/Makefile b/package/uboot-lantiq/files/board/arcadyan/arv4518/Makefile
new file mode 100644
index 0000000000..61f383b8dd
--- /dev/null
+++ b/package/uboot-lantiq/files/board/arcadyan/arv4518/Makefile
@@ -0,0 +1,47 @@
+#
+# (C) Copyright 2003-2006
+# Wolfgang Denk, DENX Software Engineering, wd@denx.de.
+#
+# See file CREDITS for list of people who contributed to this
+# project.
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2 of
+# the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston,
+# MA 02111-1307 USA
+#
+
+include $(TOPDIR)/config.mk
+
+LIB = $(obj)lib$(BOARD).a
+
+#COBJS := $(BOARD).o
+COBJS-y += arv4518.o
+
+SOBJS = lowlevel_init.o pmuenable.o
+
+SRCS := $(SOBJS:.o=.S) $(COBJS-y:.o=.c)
+OBJS := $(addprefix $(obj),$(COBJS-y))
+SOBJS := $(addprefix $(obj),$(SOBJS))
+
+$(LIB): $(obj).depend $(OBJS) $(SOBJS)
+ $(AR) $(ARFLAGS) $@ $(OBJS) $(SOBJS)
+
+#########################################################################
+
+# defines $(obj).depend target
+include $(SRCTREE)/rules.mk
+
+sinclude $(obj).depend
+
+#########################################################################