aboutsummaryrefslogtreecommitdiffstats
path: root/package/uboot-kirkwood/files/board/iomega/iconnect/Makefile
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2012-07-14 23:54:20 +0000
committerLuka Perkov <luka@openwrt.org>2012-07-14 23:54:20 +0000
commit791d9065085407b530aa41c5fb814a614b9cbaa3 (patch)
treec8ae6d5cda92fb35eee6ea40f7f6f77ba87a7a51 /package/uboot-kirkwood/files/board/iomega/iconnect/Makefile
parent59c4e41dde9c03c45033e2aa10bf508f6fd5618a (diff)
downloadupstream-791d9065085407b530aa41c5fb814a614b9cbaa3.tar.gz
upstream-791d9065085407b530aa41c5fb814a614b9cbaa3.tar.bz2
upstream-791d9065085407b530aa41c5fb814a614b9cbaa3.zip
[package] uboot-kirkwood: update to 2012.04.01
iConnect board tested by: Tim Fletcher <tim@night-shade.org.uk> Wojciech Dubowik <wojciech.dubowik@neratec.com> DockStar board tested by: Martin Mueller <mm@sig21.net> RaidSonic ICY BOX NAS6210 board tested by: Luka Perkov <uboot@lukaperkov.net> SheevaPlug was not tested but support for SheevaPlug is taken from upstream uboot and it is not reported to be broken there. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32717 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/uboot-kirkwood/files/board/iomega/iconnect/Makefile')
-rw-r--r--package/uboot-kirkwood/files/board/iomega/iconnect/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/package/uboot-kirkwood/files/board/iomega/iconnect/Makefile b/package/uboot-kirkwood/files/board/iomega/iconnect/Makefile
new file mode 100644
index 0000000000..f77fcfb990
--- /dev/null
+++ b/package/uboot-kirkwood/files/board/iomega/iconnect/Makefile
@@ -0,0 +1,43 @@
+#
+# (C) Copyright 2009
+# Marvell Semiconductor <www.marvell.com>
+# Written-by: Prafulla Wadaskar <prafulla@marvell.com>
+#
+# See file CREDITS for list of people who contributed to this
+# project.
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2 of
+# the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+
+include $(TOPDIR)/config.mk
+
+LIB = $(obj)lib$(BOARD).o
+
+COBJS := iconnect.o
+
+SRCS := $(SOBJS:.o=.S) $(COBJS:.o=.c)
+OBJS := $(addprefix $(obj),$(COBJS))
+SOBJS := $(addprefix $(obj),$(SOBJS))
+
+$(LIB): $(obj).depend $(OBJS) $(SOBJS)
+ $(call cmd_link_o_target, $(OBJS) $(SOBJS))
+
+#########################################################################
+
+# defines $(obj).depend target
+include $(SRCTREE)/rules.mk
+
+sinclude $(obj).depend
+
+#########################################################################