aboutsummaryrefslogtreecommitdiffstats
path: root/package/uboot-kirkwood/files/board/Marvell/dockstar/Makefile
diff options
context:
space:
mode:
authorLars-Peter Clausen <lars@metafoo.de>2010-08-22 16:48:28 +0000
committerLars-Peter Clausen <lars@metafoo.de>2010-08-22 16:48:28 +0000
commit84a6b4eec901247f86df863d8e869c6c051fbe68 (patch)
treed4aa49297a0237499200f36e70f7aed53d53af73 /package/uboot-kirkwood/files/board/Marvell/dockstar/Makefile
parentc52bf6423e34ddd4cb2ea4b1be4b204c52eec78f (diff)
downloadupstream-84a6b4eec901247f86df863d8e869c6c051fbe68.tar.gz
upstream-84a6b4eec901247f86df863d8e869c6c051fbe68.tar.bz2
upstream-84a6b4eec901247f86df863d8e869c6c051fbe68.zip
[package] Add uboot for marvell kirkwood based boards
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@22764 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/uboot-kirkwood/files/board/Marvell/dockstar/Makefile')
-rw-r--r--package/uboot-kirkwood/files/board/Marvell/dockstar/Makefile51
1 files changed, 51 insertions, 0 deletions
diff --git a/package/uboot-kirkwood/files/board/Marvell/dockstar/Makefile b/package/uboot-kirkwood/files/board/Marvell/dockstar/Makefile
new file mode 100644
index 0000000000..da9d29ea1f
--- /dev/null
+++ b/package/uboot-kirkwood/files/board/Marvell/dockstar/Makefile
@@ -0,0 +1,51 @@
+#
+# (C) Copyright 2009
+# Marvell Semiconductor <www.marvell.com>
+# Written-by: Prafulla Wadaskar <prafulla@marvell.com>
+#
+# See file CREDITS for list of people who contributed to this
+# project.
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2 of
+# the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston,
+# MA 02110-1301 USA
+#
+
+include $(TOPDIR)/config.mk
+
+LIB = $(obj)lib$(BOARD).a
+
+COBJS := dockstar.o
+
+SRCS := $(SOBJS:.o=.S) $(COBJS:.o=.c)
+OBJS := $(addprefix $(obj),$(COBJS))
+SOBJS := $(addprefix $(obj),$(SOBJS))
+
+$(LIB): $(obj).depend $(OBJS) $(SOBJS)
+ $(AR) $(ARFLAGS) $@ $(OBJS) $(SOBJS)
+
+clean:
+ rm -f $(SOBJS) $(OBJS)
+
+distclean: clean
+ rm -f $(LIB) core *.bak .depend
+
+#########################################################################
+
+# defines $(obj).depend target
+include $(SRCTREE)/rules.mk
+
+sinclude $(obj).depend
+
+#########################################################################