aboutsummaryrefslogtreecommitdiffstats
path: root/package/uboot-ifxmips/files/board
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2009-10-04 21:58:18 +0000
committerJohn Crispin <blogic@openwrt.org>2009-10-04 21:58:18 +0000
commit0f2923cc47cd553358e153c0b92733c98c81c1c7 (patch)
tree20fb3c2ffd7f1291782a77a3a7ed1793cf036d88 /package/uboot-ifxmips/files/board
parentd1b3ad0612032990cf954e19f86ea4897d61a57f (diff)
downloadupstream-0f2923cc47cd553358e153c0b92733c98c81c1c7.tar.gz
upstream-0f2923cc47cd553358e153c0b92733c98c81c1c7.tar.bz2
upstream-0f2923cc47cd553358e153c0b92733c98c81c1c7.zip
fixes ifxmips uboot compile, adds uart uploadable image and fix for wippies homebox flash
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@17856 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/uboot-ifxmips/files/board')
-rw-r--r--package/uboot-ifxmips/files/board/ifx/danube/config.mk2
-rw-r--r--package/uboot-ifxmips/files/board/ifx/danube/flash.c4
2 files changed, 4 insertions, 2 deletions
diff --git a/package/uboot-ifxmips/files/board/ifx/danube/config.mk b/package/uboot-ifxmips/files/board/ifx/danube/config.mk
index e6fcbc6591..88680e14f8 100644
--- a/package/uboot-ifxmips/files/board/ifx/danube/config.mk
+++ b/package/uboot-ifxmips/files/board/ifx/danube/config.mk
@@ -24,7 +24,7 @@
#
# Danube board with MIPS 24Kec CPU core
#boot from ebu
-TEXT_BASE = 0xB0000000
+#TEXT_BASE = 0xB0000000
BOOTSTRAP_TEXT_BASE = 0xB0000000
#boot from ram
diff --git a/package/uboot-ifxmips/files/board/ifx/danube/flash.c b/package/uboot-ifxmips/files/board/ifx/danube/flash.c
index 587c072d18..f8a543dbe6 100644
--- a/package/uboot-ifxmips/files/board/ifx/danube/flash.c
+++ b/package/uboot-ifxmips/files/board/ifx/danube/flash.c
@@ -720,7 +720,9 @@ int flash_erase (flash_info_t *info, int s_first, int s_last)
(*DANUBE_EBU_BUSCON0)|=0x80000000; // disable writing
(*DANUBE_EBU_BUSCON1)|=0x80000000; // disable writing
-
+
+ flash_reset(info); /* Homebox Black with JS28F128J3D75 had trouble reading after erase */
+
printf (" done\n");
return rcode;
}