aboutsummaryrefslogtreecommitdiffstats
path: root/package/uboot-ifxmips/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2009-10-04 21:58:18 +0000
committerJohn Crispin <john@openwrt.org>2009-10-04 21:58:18 +0000
commit546e37654bc064e84ba32bc85f88d7d0d2163561 (patch)
tree5ab16f32e674a228c4ce47428a1e381a3db6e0cc /package/uboot-ifxmips/Makefile
parenta70ef0c33764bc8cfc9f27403419a01a9dcebb78 (diff)
downloadupstream-546e37654bc064e84ba32bc85f88d7d0d2163561.tar.gz
upstream-546e37654bc064e84ba32bc85f88d7d0d2163561.tar.bz2
upstream-546e37654bc064e84ba32bc85f88d7d0d2163561.zip
fixes ifxmips uboot compile, adds uart uploadable image and fix for wippies homebox flash
SVN-Revision: 17856
Diffstat (limited to 'package/uboot-ifxmips/Makefile')
-rw-r--r--package/uboot-ifxmips/Makefile19
1 files changed, 13 insertions, 6 deletions
diff --git a/package/uboot-ifxmips/Makefile b/package/uboot-ifxmips/Makefile
index 8cc8b601c6..b445356f5e 100644
--- a/package/uboot-ifxmips/Makefile
+++ b/package/uboot-ifxmips/Makefile
@@ -41,7 +41,7 @@ UBOOT_MAKE_OPTS:=\
CROSS_COMPILE_UCLIBC=1 \
COMPRESS=lzma \
PLATFORM_CPU=mips32r2 \
- UBOOT_RAM_TEXT_BASE=0xA0400000
+ UBOOT_RAM_TEXT_BASE=0xA0400000 \
define Build/Configure
$(MAKE) -s -C $(PKG_BUILD_DIR) \
@@ -50,18 +50,25 @@ define Build/Configure
endef
define Build/Compile
- $(MAKE) -s -C $(PKG_BUILD_DIR) \
+ $(MAKE) -C $(PKG_BUILD_DIR) \
$(UBOOT_MAKE_OPTS) \
+ OWRT_FLAGS="-DTEXT_BASE=0xa0400000" \
ifx_all
- if [ `stat -c%s $(PKG_BUILD_DIR)/u-boot.ifx` -gt 65536 ] ;\
- then \
- echo "u-boot.ifx file has exceeded 64MB in size."; exit 1; \
- fi
+ $(CP) $(PKG_BUILD_DIR)/u-boot.srec $(PKG_BUILD_DIR)/asc.srec
+ $(PKG_BUILD_DIR)/gct \
+ $(PKG_BUILD_DIR)/danube_ref_ddr166.conf \
+ $(PKG_BUILD_DIR)/asc.srec \
+ $(PKG_BUILD_DIR)/u-boot.asc
+ $(MAKE) -C $(PKG_BUILD_DIR) \
+ $(UBOOT_MAKE_OPTS) \
+ OWRT_FLAGS="-DDANUBE_BOOT_FROM_EBU=1 -DTEXT_BASE=0xB0000000" \
+ clean ifx_all
endef
define Package/uboot-ifxmips/install
mkdir -p $(1)
dd if=$(PKG_BUILD_DIR)/u-boot.ifx of=$(1)/u-boot.ifx bs=64k conv=sync
+ $(CP) $(PKG_BUILD_DIR)/u-boot.asc $(1)
endef
$(eval $(call BuildPackage,uboot-ifxmips))