aboutsummaryrefslogtreecommitdiffstats
path: root/package/uboot-envtools
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2012-07-16 22:32:00 +0000
committerLuka Perkov <luka@openwrt.org>2012-07-16 22:32:00 +0000
commit3257875e1b49e9f62c687bcb826f2b8f633c0441 (patch)
tree9eff58c8402d788af0b1dd9eed05cd7efe443e55 /package/uboot-envtools
parente59b60d1dd623c943cbc825265f773b634f0b828 (diff)
downloadupstream-3257875e1b49e9f62c687bcb826f2b8f633c0441.tar.gz
upstream-3257875e1b49e9f62c687bcb826f2b8f633c0441.tar.bz2
upstream-3257875e1b49e9f62c687bcb826f2b8f633c0441.zip
[package] uboot-envtools: add kirkwood board support
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32756 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/uboot-envtools')
-rw-r--r--package/uboot-envtools/Makefile4
-rw-r--r--package/uboot-envtools/files/kirkwood25
2 files changed, 29 insertions, 0 deletions
diff --git a/package/uboot-envtools/Makefile b/package/uboot-envtools/Makefile
index 45f7430b88..8169840d9a 100644
--- a/package/uboot-envtools/Makefile
+++ b/package/uboot-envtools/Makefile
@@ -69,6 +69,10 @@ ifneq ($(CONFIG_TARGET_ar71xx),)
$(INSTALL_DIR) $(1)/etc/uci-defaults
$(INSTALL_BIN) ./files/ar71xx $(1)/etc/uci-defaults/uboot-envtools
endif
+ifneq ($(CONFIG_TARGET_kirkwood),)
+ $(INSTALL_DIR) $(1)/etc/uci-defaults
+ $(INSTALL_BIN) ./files/kirkwood $(1)/etc/uci-defaults/uboot-envtools
+endif
ifneq ($(CONFIG_TARGET_lantiq),)
$(INSTALL_DIR) $(1)/etc/uci-defaults
$(INSTALL_BIN) ./files/lantiq $(1)/etc/uci-defaults/uboot-envtools
diff --git a/package/uboot-envtools/files/kirkwood b/package/uboot-envtools/files/kirkwood
new file mode 100644
index 0000000000..cad53aa379
--- /dev/null
+++ b/package/uboot-envtools/files/kirkwood
@@ -0,0 +1,25 @@
+#!/bin/sh
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+
+[ -e /etc/config/ubootenv ] && exit 0
+
+touch /etc/config/ubootenv
+
+. /lib/kirkwood.sh
+. /lib/uboot-envtools.sh
+. /lib/functions.sh
+
+hardware=$(kirkwood_hardware_name)
+
+case "$hardware" in
+"RaidSonic ICY BOX IB-NAS6210")
+ ubootenv_add_uci_config "/dev/mtd1" "0x0" "0x20000" "0x20000"
+ ;;
+esac
+
+config_load ubootenv
+config_foreach ubootenv_add_app_config ubootenv
+
+exit 0