aboutsummaryrefslogtreecommitdiffstats
path: root/package/uboot-envtools/Makefile
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2009-10-07 15:14:28 +0000
committerFlorian Fainelli <florian@openwrt.org>2009-10-07 15:14:28 +0000
commit7a7a5627cd47245ad50d2868bb4df72f28405001 (patch)
treec00db65e2411a9d782dd554b09b3eecf50624c4e /package/uboot-envtools/Makefile
parent96d804c54f2968987455be55efaed0940fb87d36 (diff)
downloadupstream-7a7a5627cd47245ad50d2868bb4df72f28405001.tar.gz
upstream-7a7a5627cd47245ad50d2868bb4df72f28405001.tar.bz2
upstream-7a7a5627cd47245ad50d2868bb4df72f28405001.zip
add uboot-envtools
SVN-Revision: 17981
Diffstat (limited to 'package/uboot-envtools/Makefile')
-rw-r--r--package/uboot-envtools/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/package/uboot-envtools/Makefile b/package/uboot-envtools/Makefile
new file mode 100644
index 0000000000..8a3600ac8e
--- /dev/null
+++ b/package/uboot-envtools/Makefile
@@ -0,0 +1,34 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=uboot-envtools
+PKG_VERSION:=20081215
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
+PKG_SOURCE_URL:=http://ftp.de.debian.org/debian/pool/main/u/uboot-envtools/
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/uboot-envtools
+ SECTION:=utils
+ CATEGORY:=Utilities
+ TITLE:=read/modify the environment for the bootloader U-Boot
+endef
+
+define Package/uboot-envtools/description
+endef
+
+define Package/uboot-envtools/install
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/fw_printenv $(1)/usr/sbin/
+ ln -s fw_printenv $(1)/usr/sbin/fw_setenv
+endef
+
+$(eval $(call BuildPackage,uboot-envtools))