aboutsummaryrefslogtreecommitdiffstats
path: root/package/uboot-ar71xx/patches/011-switch-rtl8366sr.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2010-12-10 15:17:00 +0000
committerGabor Juhos <juhosg@openwrt.org>2010-12-10 15:17:00 +0000
commit89cf40ace9fb8a2214e57f95186230d3c7f090a5 (patch)
tree088f8c75e620205a8e04b98bf882c5db21ee038d /package/uboot-ar71xx/patches/011-switch-rtl8366sr.patch
parentdde3336f0d71b70caadbe0a7635d873700bb8857 (diff)
downloadupstream-89cf40ace9fb8a2214e57f95186230d3c7f090a5.tar.gz
upstream-89cf40ace9fb8a2214e57f95186230d3c7f090a5.tar.bz2
upstream-89cf40ace9fb8a2214e57f95186230d3c7f090a5.zip
ar71xx: adding u-boot for nbg460n
This adds u-boot for nbg460n ar71xx target, as it is required as second stage bootloader. Signed-off-by: Michael Kurz <michi.kurz@googlemail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@24418 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/uboot-ar71xx/patches/011-switch-rtl8366sr.patch')
-rw-r--r--package/uboot-ar71xx/patches/011-switch-rtl8366sr.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/package/uboot-ar71xx/patches/011-switch-rtl8366sr.patch b/package/uboot-ar71xx/patches/011-switch-rtl8366sr.patch
new file mode 100644
index 0000000000..5d2ba41eae
--- /dev/null
+++ b/package/uboot-ar71xx/patches/011-switch-rtl8366sr.patch
@@ -0,0 +1,28 @@
+diff -ur u-boot-2010.03/drivers/net/Makefile u-boot-nbg/drivers/net/Makefile
+--- u-boot-2010.03/drivers/net/Makefile 2010-03-31 23:54:39.000000000 +0200
++++ u-boot-nbg/drivers/net/Makefile 2010-04-19 23:30:01.000000000 +0200
+@@ -65,6 +65,7 @@
+ COBJS-$(CONFIG_DRIVER_RTL8019) += rtl8019.o
+ COBJS-$(CONFIG_RTL8139) += rtl8139.o
+ COBJS-$(CONFIG_RTL8169) += rtl8169.o
++COBJS-$(CONFIG_RTL8366_MII) += phy/rtl8366_mii.o
+ COBJS-$(CONFIG_DRIVER_S3C4510_ETH) += s3c4510b_eth.o
+ COBJS-$(CONFIG_SH_ETHER) += sh_eth.o
+ COBJS-$(CONFIG_SMC91111) += smc91111.o
+diff -ur u-boot-2010.03/include/netdev.h u-boot-nbg/include/netdev.h
+--- u-boot-2010.03/include/netdev.h 2010-03-31 23:54:39.000000000 +0200
++++ u-boot-nbg/include/netdev.h 2010-05-02 11:30:58.000000000 +0200
+@@ -175,5 +175,13 @@
+
+ int mv88e61xx_switch_initialize(struct mv88e61xx_config *swconfig);
+ #endif /* CONFIG_MV88E61XX_SWITCH */
++
++#if defined(CONFIG_RTL8366_MII)
++#define RTL8366_DEVNAME "rtl8366"
++#define RTL8366_WANPHY_ID 4
++#define RTL8366_LANPHY_ID -1
++int rtl8366_mii_register(bd_t *bis);
++int rtl8366s_initialize(void);
++#endif
+
+ #endif /* _NETDEV_H_ */