aboutsummaryrefslogtreecommitdiffstats
path: root/package/uboot-ar71xx/patches/001-ar71xx.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2010-12-10 15:17:00 +0000
committerGabor Juhos <juhosg@openwrt.org>2010-12-10 15:17:00 +0000
commit89cf40ace9fb8a2214e57f95186230d3c7f090a5 (patch)
tree088f8c75e620205a8e04b98bf882c5db21ee038d /package/uboot-ar71xx/patches/001-ar71xx.patch
parentdde3336f0d71b70caadbe0a7635d873700bb8857 (diff)
downloadupstream-89cf40ace9fb8a2214e57f95186230d3c7f090a5.tar.gz
upstream-89cf40ace9fb8a2214e57f95186230d3c7f090a5.tar.bz2
upstream-89cf40ace9fb8a2214e57f95186230d3c7f090a5.zip
ar71xx: adding u-boot for nbg460n
This adds u-boot for nbg460n ar71xx target, as it is required as second stage bootloader. Signed-off-by: Michael Kurz <michi.kurz@googlemail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@24418 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/uboot-ar71xx/patches/001-ar71xx.patch')
-rw-r--r--package/uboot-ar71xx/patches/001-ar71xx.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/package/uboot-ar71xx/patches/001-ar71xx.patch b/package/uboot-ar71xx/patches/001-ar71xx.patch
new file mode 100644
index 0000000000..409f67a57c
--- /dev/null
+++ b/package/uboot-ar71xx/patches/001-ar71xx.patch
@@ -0,0 +1,28 @@
+diff -ur u-boot-2010.03/cpu/mips/Makefile u-boot-nbg/cpu/mips/Makefile
+--- u-boot-2010.03/cpu/mips/Makefile 2010-03-31 23:54:39.000000000 +0200
++++ u-boot-nbg/cpu/mips/Makefile 2010-04-15 18:58:01.000000000 +0200
+@@ -33,6 +33,7 @@
+ COBJS-$(CONFIG_INCA_IP) += asc_serial.o incaip_clock.o
+ COBJS-$(CONFIG_PURPLE) += asc_serial.o
+ COBJS-$(CONFIG_SOC_AU1X00) += au1x00_eth.o au1x00_serial.o au1x00_usb_ohci.o
++COBJS-$(CONFIG_AR71XX) += ar71xx_serial.o
+
+ SRCS := $(START:.o=.S) $(SOBJS-y:.o=.S) $(COBJS-y:.o=.c)
+ OBJS := $(addprefix $(obj),$(SOBJS-y) $(COBJS-y))
+diff -ur u-boot-2010.03/Makefile u-boot-nbg/Makefile
+--- u-boot-2010.03/Makefile 2010-03-31 23:54:39.000000000 +0200
++++ u-boot-nbg/Makefile 2010-04-11 23:31:29.000000000 +0200
+@@ -3455,6 +3455,13 @@
+ @$(MKCONFIG) -a qemu-mips mips mips qemu-mips
+
+ #########################################################################
++## MIPS32 AR71XX (24K)
++#########################################################################
++
++nbg460n_550n_550nh_config : unconfig
++ @$(MKCONFIG) -a nbg460n mips mips nbg460n zyxel
++
++#########################################################################
+ ## MIPS64 5Kc
+ #########################################################################
+