aboutsummaryrefslogtreecommitdiffstats
path: root/package/toolchain
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2013-01-09 15:36:43 +0000
committerFlorian Fainelli <florian@openwrt.org>2013-01-09 15:36:43 +0000
commit19ef28eb3b40ddb0caa71a290bdbf66592f4af47 (patch)
treee0e329ba99b73c051bc5105b65cab5c2b3a0719f /package/toolchain
parent6ae52f05eb27fc164f092035d54ee109f0c56697 (diff)
downloadupstream-19ef28eb3b40ddb0caa71a290bdbf66592f4af47.tar.gz
upstream-19ef28eb3b40ddb0caa71a290bdbf66592f4af47.tar.bz2
upstream-19ef28eb3b40ddb0caa71a290bdbf66592f4af47.zip
toolchain: fix libpthread package for musl based toolchains (#12651)
Signed-off-by: Florian Fainelli <florian@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@35069 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/toolchain')
-rw-r--r--package/toolchain/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/toolchain/Makefile b/package/toolchain/Makefile
index 84fc3e6b2f..ec5508a754 100644
--- a/package/toolchain/Makefile
+++ b/package/toolchain/Makefile
@@ -451,6 +451,7 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
define Package/libpthread/install
$(INSTALL_DIR) $(1)/lib
+ ifneq ($(CONFIG_USE_MUSL),y)
$(CP) \
$(TOOLCHAIN_DIR)/lib/libpthread.so.* \
$(if $(BUILD_LIBGCC),\
@@ -458,6 +459,7 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
$(TOOLCHAIN_DIR)/lib/libpthread-$(LIBC_SO_VERSION).so \
) \
$(1)/lib/
+ endif
endef
define Package/libthread-db/install