aboutsummaryrefslogtreecommitdiffstats
path: root/package/system
diff options
context:
space:
mode:
authorRafał Miłecki <rafal@milecki.pl>2019-07-03 11:16:22 +0200
committerJo-Philipp Wich <jo@mein.io>2019-09-04 13:27:52 +0200
commit67b3e4446534553968262ec9e4b62dba47272f0d (patch)
tree8d3bfa22f8caeec7c69d4a703fdaa4ea8846298a /package/system
parentff9255f7a188b311383b7e460987f468837c21e3 (diff)
downloadupstream-67b3e4446534553968262ec9e4b62dba47272f0d.tar.gz
upstream-67b3e4446534553968262ec9e4b62dba47272f0d.tar.bz2
upstream-67b3e4446534553968262ec9e4b62dba47272f0d.zip
ubox: implement service_running() in log init.d script
It allows checking if service is running. Signed-off-by: Rafał Miłecki <rafal@milecki.pl> (cherry picked from commit 1b937cb14184b5ff9a7a75fbc5d226032f931c35)
Diffstat (limited to 'package/system')
-rw-r--r--package/system/ubox/Makefile2
-rw-r--r--package/system/ubox/files/log.init4
2 files changed, 5 insertions, 1 deletions
diff --git a/package/system/ubox/Makefile b/package/system/ubox/Makefile
index 9631ac872f..6e67951929 100644
--- a/package/system/ubox/Makefile
+++ b/package/system/ubox/Makefile
@@ -1,7 +1,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=ubox
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL=$(PROJECT_GIT)/project/ubox.git
diff --git a/package/system/ubox/files/log.init b/package/system/ubox/files/log.init
index 250f805b44..ba9c124c8b 100644
--- a/package/system/ubox/files/log.init
+++ b/package/system/ubox/files/log.init
@@ -96,3 +96,7 @@ start_service()
config_foreach validate_log_section system start_service_file
config_foreach validate_log_section system start_service_remote
}
+
+service_running() {
+ procd_running log
+}