aboutsummaryrefslogtreecommitdiffstats
path: root/package/system
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2019-12-28 08:00:47 +0100
committerPetr Štetiar <ynezz@true.cz>2020-01-05 17:50:10 +0100
commit64c45d95d622bf9f3727843fe6e05de71d310a9c (patch)
treed39a78ef95e6e2449f375e21e3f17603e2b3623e /package/system
parent04fd5e22b24259725a7932b3be0916c3fa750f64 (diff)
downloadupstream-64c45d95d622bf9f3727843fe6e05de71d310a9c.tar.gz
upstream-64c45d95d622bf9f3727843fe6e05de71d310a9c.tar.bz2
upstream-64c45d95d622bf9f3727843fe6e05de71d310a9c.zip
ubus: update to version 2019-12-27
Contains following changes: 041c9d1c052b ubusd/libubus-io: fix socket descriptor passing 8f2292478c57 ci: enable unit testing a1523d76b016 fix blob parsing vulnerability by using blob_parse_untrusted c60583743ccf ubus_monitor: workaround possibly false positive uses of memory after it is freed dac6c7c575ac ubusd_monitor: fix possible null pointer dereference 060dfbb26da3 ubus_common: remove duplicate ARRAY_SIZE and add missing include c5f2053dfcfd workaround possibly false positive uses of memory after it is freed 72be8e93f07d lua: ubus_lua_do_subscribe: fix copy&paste error a995b1e68129 lua: workaround false positive dereference of null pointer 08f17c87a000 add fuzzer and cram based unit tests c413be9b376c refactor ubusd.c into reusable ubusd_library afd47189e864 examples: remove dead increments b2e544238672 add initial GitLab CI support 058f4e9526ed libubus: fix incompatible pointer types assigment d2e026a33df8 iron out all extra compiler warnings 5d7ca8309d0a ubusd/libubus-io: fix variable sized struct position warning d61282db5640 ubusd: fix comparison of integers of different signs 90fb16234c22 cmake: enable extra compiler checks 2e051f628996 ubus: Support static builds 588baa3cd784 ubusd: retry sending messages on EINTR 76ea27a62774 libubus: attempt to receive data before calling poll 4daab27d004f libubus: do not abort recv_retry before completing a message and bumps ABI_VERSION to 20191227. Acked-by: Hauke Mehrtens <hauke@hauke-m.de> Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'package/system')
-rw-r--r--package/system/ubus/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/package/system/ubus/Makefile b/package/system/ubus/Makefile
index 6653132351..d3fe452252 100644
--- a/package/system/ubus/Makefile
+++ b/package/system/ubus/Makefile
@@ -5,9 +5,9 @@ PKG_RELEASE:=1
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL=$(PROJECT_GIT)/project/ubus.git
-PKG_SOURCE_DATE:=2018-10-06
-PKG_SOURCE_VERSION:=221ce7e7ff1bd1a0c9995fa9d32f58e865f7207f
-PKG_MIRROR_HASH:=e6ab3f009688740eb6d7a1857df59a6ba10ae8ae0fac78ae0fd6672f71c02dce
+PKG_SOURCE_DATE:=2019-12-27
+PKG_SOURCE_VERSION:=041c9d1c052bb4936fd03240f7d0dd64aedda972
+PKG_MIRROR_HASH:=7febbe78dd178d8d7ccacff54c00fb2d19a53624005920db8cd85236f54f8324
CMAKE_INSTALL:=1
PKG_LICENSE:=LGPL-2.1
@@ -36,7 +36,7 @@ define Package/libubus
SECTION:=libs
CATEGORY:=Libraries
DEPENDS:=+libubox
- ABI_VERSION:=20170705
+ ABI_VERSION:=20191227
TITLE:=OpenWrt RPC client library
endef