aboutsummaryrefslogtreecommitdiffstats
path: root/package/system
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2019-06-15 14:57:14 +0200
committerJo-Philipp Wich <jo@mein.io>2019-09-04 13:15:40 +0200
commit1754dc2ddba23453da158a8430f7f31b7dfe26d9 (patch)
treece407f66782c8bea90e5613d9e2b19702a6b5617 /package/system
parente7ccc34478965654fe9b89e5cefac955d18f53de (diff)
downloadupstream-1754dc2ddba23453da158a8430f7f31b7dfe26d9.tar.gz
upstream-1754dc2ddba23453da158a8430f7f31b7dfe26d9.tar.bz2
upstream-1754dc2ddba23453da158a8430f7f31b7dfe26d9.zip
treewide: fix syntax errors exposed after kconfig update
After commit e82a4d9cfb ("config: regenerate *_shipped sources") the mconf parser became more strict as a side effect and started to spew a series of warnings when evaluating our generated kconfig sources: tmp/.config-package.in:705:warning: ignoring unsupported character '@' The root cause of these warnings is a wrong use of the @SYMBOL dependency syntax in various Makefile. Fix the corresponding Makefiles by turning `@SYM||@SYM2` expressions into the proper `@(SYM||SYM2)` form. Signed-off-by: Jo-Philipp Wich <jo@mein.io> (cherry picked from commit 74739c4228f3bd0aa757165c67c53016c3deb544)
Diffstat (limited to 'package/system')
-rw-r--r--package/system/procd/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/system/procd/Makefile b/package/system/procd/Makefile
index a58e449155..dce6205502 100644
--- a/package/system/procd/Makefile
+++ b/package/system/procd/Makefile
@@ -58,7 +58,7 @@ endef
define Package/procd-seccomp
SECTION:=base
CATEGORY:=Base system
- DEPENDS:=@arm||@armeb||@mips||@mipsel||@i386||@powerpc||@x86_64 @!TARGET_uml @KERNEL_SECCOMP +libubox +libblobmsg-json
+ DEPENDS:=@(arm||armeb||mips||mipsel||i386||powerpc||x86_64) @!TARGET_uml @KERNEL_SECCOMP +libubox +libblobmsg-json
TITLE:=OpenWrt process seccomp helper + utrace
endef