aboutsummaryrefslogtreecommitdiffstats
path: root/package/system
diff options
context:
space:
mode:
authorMichal Sojka <sojkam1@fel.cvut.cz>2017-11-03 22:31:42 +0100
committerJo-Philipp Wich <jo@mein.io>2017-12-13 16:44:07 +0100
commit5872c19c63b61ad481f54eb7c415e52e22b15b91 (patch)
tree0148ac02caa32153befe8c73c75d96d42cfa2175 /package/system
parentcd901ef1a60437de6ceac5da07f53a10046096e1 (diff)
downloadupstream-5872c19c63b61ad481f54eb7c415e52e22b15b91.tar.gz
upstream-5872c19c63b61ad481f54eb7c415e52e22b15b91.tar.bz2
upstream-5872c19c63b61ad481f54eb7c415e52e22b15b91.zip
procd: Always tell cmake whether to include seccomp support or not
Without this change, when a user disables seccomp support in .config, procd does not get recompiled unless the package is cleaned manually. It is because when -D option is missing from cmake command line, cmake uses cached value from the previous run where seccomp was enabled. Signed-off-by: Michal Sojka <sojkam1@fel.cvut.cz> (cherry picked from commit 0e300a3a71264d8938b17f9fb0d5f1ab33a0434a)
Diffstat (limited to 'package/system')
-rw-r--r--package/system/procd/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/package/system/procd/Makefile b/package/system/procd/Makefile
index a2fea4dc12..93164ea69b 100644
--- a/package/system/procd/Makefile
+++ b/package/system/procd/Makefile
@@ -107,9 +107,8 @@ ifdef CONFIG_PACKAGE_procd-ujail
CMAKE_OPTIONS += -DJAIL_SUPPORT=1
endif
-ifdef CONFIG_PACKAGE_procd-seccomp
- CMAKE_OPTIONS += -DSECCOMP_SUPPORT=1 -DUTRACE_SUPPORT=1
-endif
+SECCOMP=$(if $(CONFIG_PACKAGE_procd-seccomp),1,0)
+CMAKE_OPTIONS += -DSECCOMP_SUPPORT=$(SECCOMP) -DUTRACE_SUPPORT=$(SECCOMP)
define Package/procd/install
$(INSTALL_DIR) $(1)/sbin $(1)/etc $(1)/lib/functions