aboutsummaryrefslogtreecommitdiffstats
path: root/package/system
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2017-04-25 20:26:38 +0800
committerYousong Zhou <yszhou4tech@gmail.com>2017-04-27 14:38:05 +0800
commit2bc8d5eaf17823ddd319f5fd3e9fb880535ed696 (patch)
treee32c2c127821921dfc2472c77174cafa2ab76652 /package/system
parent1ab41265c39354332630bcba0ec704abd2e790f0 (diff)
downloadupstream-2bc8d5eaf17823ddd319f5fd3e9fb880535ed696.tar.gz
upstream-2bc8d5eaf17823ddd319f5fd3e9fb880535ed696.tar.bz2
upstream-2bc8d5eaf17823ddd319f5fd3e9fb880535ed696.zip
ubox: bump to version 2017-03-10
Fixes FS#684 with commit 21a4bd0 Changes since current version. All changes except the ones prefixed with asterisks are for bugfixes. Module aliases awareness is expected by the kernel to be a basic facility and is required for properly initializing wireguard. 16f7e16 syslog: remove unnecessary sizeof struct between messages 21a4bd0 kmodloader: modprobe: return 0 for loaded modules 3dc78a4 kmodloader: don't store aliases info in struct module c553354 cmake: fix typo 8973576 kmodloader: fix not being able to find some modules fce9382 cmake: Check for getrandom system call ac2d43e kmodloader: support '-q' quiet option *f8d3d16 ubox: Add an option for more accurate timestamps in log 14839f0 kmodloader: make insert_module() idempotent *6e3c6dc kmodloader: add module alias awareness 9371411 kmodloader: fix out-of-bound access when parsing .modinfo a62c946 kmodloader: modprobe: skip possible command line arguments *46a4b5f kmodloader: log to kmsg when loading directories of modules eacc426 kmodloader: remove redundant glob wildcard char 8488bb5 ubox: Initialize conditionally uninitialized variabled db070f1 ubox: Fix some memory leaks acc48b5 kmodloader: Fix typo in error message Size comparison on x86_64 host function old new delta main 2190 2344 +154 scan_module_folder 665 793 +128 alloc_module_node - 113 +113 .rodata 946 1036 +90 alloc_module 202 245 +43 free_modules 77 119 +42 load_modprobe 209 237 +28 scan_loaded_modules 241 265 +24 avl_modcmp 45 67 +22 insert_module 204 224 +20 find_module 13 30 +17 static.optind@@GLIBC_2 - 4 +4 static.load_moddeps 118 117 -1 scan_module_folders 55 54 -1 ------------------------------------------------------------------------------ (add/remove: 2/0 grow/shrink: 10/2 up/down: 685/-2) Total: 683 bytes Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
Diffstat (limited to 'package/system')
-rw-r--r--package/system/ubox/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/system/ubox/Makefile b/package/system/ubox/Makefile
index cdf9265d31..3c9b4aa515 100644
--- a/package/system/ubox/Makefile
+++ b/package/system/ubox/Makefile
@@ -5,9 +5,9 @@ PKG_RELEASE:=1
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL=$(LEDE_GIT)/project/ubox.git
-PKG_SOURCE_DATE:=2017-01-15
-PKG_SOURCE_VERSION:=5649c028c426060616e2bd4e7ea83271cd333d21
-PKG_MIRROR_HASH:=28e5580d481a415697fbca46c160177bab6dc47a04ba7ddb73537827632b2dd6
+PKG_SOURCE_DATE:=2017-03-10
+PKG_SOURCE_VERSION:=16f7e16181e2f3e9cf3e2ce56a7e291844900d09
+PKG_MIRROR_HASH:=5f10f3df134eb8a69d281a73d39f5d2e2fc96af531a2f3960b0c6116ff11a707
CMAKE_INSTALL:=1
PKG_LICENSE:=GPL-2.0