aboutsummaryrefslogtreecommitdiffstats
path: root/package/system
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-06-30 09:57:29 +0000
committerJohn Crispin <blogic@openwrt.org>2014-06-30 09:57:29 +0000
commit1a7223795f4fa449b5c85bc97bc7454f103a0c85 (patch)
treeeb771a496273f640b41dcb9fbecf57e9f2470790 /package/system
parent6f80caf974f8061993477b155f5ca72df5471d4f (diff)
downloadupstream-1a7223795f4fa449b5c85bc97bc7454f103a0c85.tar.gz
upstream-1a7223795f4fa449b5c85bc97bc7454f103a0c85.tar.bz2
upstream-1a7223795f4fa449b5c85bc97bc7454f103a0c85.zip
procd: fix uci_validation
Regardles of the return code from validate_data _error variable will be 0 due to 'local' command in the previous line. With this patch we are able to catch the return code from validate_data tool. Signed-off-by: Luka Perkov <luka@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41414 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/system')
-rw-r--r--package/system/procd/Makefile9
-rw-r--r--package/system/procd/files/procd.sh3
2 files changed, 10 insertions, 2 deletions
diff --git a/package/system/procd/Makefile b/package/system/procd/Makefile
index 6553fcc831..30bcd2a7f2 100644
--- a/package/system/procd/Makefile
+++ b/package/system/procd/Makefile
@@ -1,7 +1,14 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
include $(TOPDIR)/rules.mk
PKG_NAME:=procd
-PKG_VERSION:=2014-06-19
+PKG_VERSION:=2014-06-27
PKG_RELEASE=$(PKG_SOURCE_VERSION)
diff --git a/package/system/procd/files/procd.sh b/package/system/procd/files/procd.sh
index 67924a2749..c5fd512486 100644
--- a/package/system/procd/files/procd.sh
+++ b/package/system/procd/files/procd.sh
@@ -269,9 +269,10 @@ uci_validate_section()
local _package="$1"
local _type="$2"
local _name="$3"
+ local _result
local _error
shift; shift; shift
- local _result=`/sbin/validate_data "$_package" "$_type" "$_name" "$@" 2> /dev/null`
+ _result=`/sbin/validate_data "$_package" "$_type" "$_name" "$@" 2> /dev/null`
_error=$?
eval "$_result"
[ "$_error" = "0" ] || `/sbin/validate_data "$_package" "$_type" "$_name" "$@" 1> /dev/null`