aboutsummaryrefslogtreecommitdiffstats
path: root/package/system/ubus
diff options
context:
space:
mode:
authorAndre Heider <a.heider@gmail.com>2023-02-02 21:33:38 +0100
committerChristian Marangi <ansuelsmth@gmail.com>2023-03-21 18:28:22 +0100
commit07730ff3465d3cede3026cdd1c17453930f055ce (patch)
tree71c8f06b42de3b1ff0d1c02c0068d718c3a08a62 /package/system/ubus
parentda3700988d9e34e380bae21ee23d5458a7e972b4 (diff)
downloadupstream-07730ff3465d3cede3026cdd1c17453930f055ce.tar.gz
upstream-07730ff3465d3cede3026cdd1c17453930f055ce.tar.bz2
upstream-07730ff3465d3cede3026cdd1c17453930f055ce.zip
treewide: add support for "lto" in PKG_BUILD_FLAGS
This reduces open coding and allows to easily add a knob to enable it treewide, where chosen packages can still opt-out via "no-lto". Some packages used LTO, but not the linker plugin. This unifies 'em all to attempt to produce better code. Quoting man gcc(1): "This improves the quality of optimization by exposing more code to the link-time optimizer." Also use -flto=auto instead of -flto=jobserver, as it's not guaranteed that every buildsystem uses +$(MAKE) correctly. Signed-off-by: Andre Heider <a.heider@gmail.com>
Diffstat (limited to 'package/system/ubus')
-rw-r--r--package/system/ubus/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/system/ubus/Makefile b/package/system/ubus/Makefile
index 4c72780703..5a951ac249 100644
--- a/package/system/ubus/Makefile
+++ b/package/system/ubus/Makefile
@@ -15,6 +15,7 @@ PKG_LICENSE:=LGPL-2.1
PKG_LICENSE_FILES:=
PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
+PKG_BUILD_FLAGS:=lto
PKG_ASLR_PIE_REGULAR:=1
include $(INCLUDE_DIR)/package.mk
@@ -50,8 +51,7 @@ define Package/libubus-lua
TITLE:=Lua binding for the OpenWrt RPC client
endef
-TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include -flto
-TARGET_LDFLAGS += -flto
+TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include
CMAKE_OPTIONS += \
-DLUAPATH=/usr/lib/lua \