aboutsummaryrefslogtreecommitdiffstats
path: root/package/system/rpcd
diff options
context:
space:
mode:
authorFlorian Fainelli <f.fainelli@gmail.com>2016-12-31 16:13:34 -0800
committerJo-Philipp Wich <jo@mein.io>2017-04-28 17:09:13 +0200
commite200c66a1ad1ac62007084629da5dcc28ed822a0 (patch)
tree2c4f664d31dfff87dac50e00cf7508c7f70b0f09 /package/system/rpcd
parent28d626556d846ce69246d72e2a0e3a008e5fc7dd (diff)
downloadupstream-e200c66a1ad1ac62007084629da5dcc28ed822a0.tar.gz
upstream-e200c66a1ad1ac62007084629da5dcc28ed822a0.tar.bz2
upstream-e200c66a1ad1ac62007084629da5dcc28ed822a0.zip
rpcd: Explicitly link with lcrypt
Fixes build issues with some toolchains that don't add lcrypt in the default search paths: CMakeFiles/rpcd.dir/session.c.o: In function `rpc_login_test_password': build_dir/target-mipsel-linux-gnu/rpcd-2016-12-03-0577cfc1/session.c:823: undefined reference to `crypt' collect2: error: ld returned 1 exit status Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
Diffstat (limited to 'package/system/rpcd')
-rw-r--r--package/system/rpcd/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/system/rpcd/Makefile b/package/system/rpcd/Makefile
index 9da7df85fb..d13f20eab4 100644
--- a/package/system/rpcd/Makefile
+++ b/package/system/rpcd/Makefile
@@ -51,6 +51,8 @@ define Package/rpcd/conffiles
/etc/config/rpcd
endef
+TARGET_LDFLAGS += -lcrypt
+
define Package/rpcd/install
$(INSTALL_DIR) $(1)/etc/init.d
$(INSTALL_BIN) ./files/rpcd.init $(1)/etc/init.d/rpcd