aboutsummaryrefslogtreecommitdiffstats
path: root/package/system/opkg/Makefile
diff options
context:
space:
mode:
authorSteven Barth <cyrus@openwrt.org>2013-10-02 12:12:10 +0000
committerSteven Barth <cyrus@openwrt.org>2013-10-02 12:12:10 +0000
commitcbdd346b11c6f125f48cdb1e95870d16e5c0d628 (patch)
treea6c5edbe734be83f8bcd880083de81f5060132ab /package/system/opkg/Makefile
parent0ad1d06c13a15a9e91cc7a1a635ac678a298ed7f (diff)
downloadupstream-cbdd346b11c6f125f48cdb1e95870d16e5c0d628.tar.gz
upstream-cbdd346b11c6f125f48cdb1e95870d16e5c0d628.tar.bz2
upstream-cbdd346b11c6f125f48cdb1e95870d16e5c0d628.zip
Add package signing infrastructure
Add package signing key and certificate configuration options to the "Image configuration" submenu. If enabled, the Packages.gz list will be signed as file Packages.sig. The passphrase for the signing key can be sourced from a file or entered by the user. The signing certificate is automatically added to the firmware image if opkg-smime is selected. Signed-off-by: Evan Hunt <each@isc.org> Signed-off-by: Steven Barth <steven@midlink.org> SVN-Revision: 38284
Diffstat (limited to 'package/system/opkg/Makefile')
-rw-r--r--package/system/opkg/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/package/system/opkg/Makefile b/package/system/opkg/Makefile
index eb3b10a776..3327a8e1ad 100644
--- a/package/system/opkg/Makefile
+++ b/package/system/opkg/Makefile
@@ -109,8 +109,12 @@ define Package/opkg/Default/install
endef
Package/opkg/install = $(call Package/opkg/Default/install,$(1),)
-Package/opkg-smime/install = $(call Package/opkg/Default/install,$(1),-smime)
+define Package/opkg-smime/install
+ $(call Package/opkg/Default/install,$(1),-smime)
+ $(INSTALL_DIR) $(1)/etc/ssl/certs
+ $(if $(CONFIG_OPKGSMIME_CERT),$(INSTALL_DATA) $(call qstrip,$(CONFIG_OPKGSMIME_CERT)) $(1)/etc/ssl/certs/opkg.pem,)
+endef
define Build/InstallDev
mkdir -p $(1)/usr/include