aboutsummaryrefslogtreecommitdiffstats
path: root/package/system/opkg/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2016-09-14 20:50:35 +0200
committerFelix Fietkau <nbd@nbd.name>2016-12-27 09:50:00 +0100
commite1d1c3189093ebe384953519083f815a420c4a4e (patch)
tree369a94779f5520fc26bb13e2f274d75c4b454c83 /package/system/opkg/Makefile
parentdc5f496a0df8d125ce172fc40100098b18da2300 (diff)
downloadupstream-e1d1c3189093ebe384953519083f815a420c4a4e.tar.gz
upstream-e1d1c3189093ebe384953519083f815a420c4a4e.tar.bz2
upstream-e1d1c3189093ebe384953519083f815a420c4a4e.zip
opkg: vfork external gzip command to uncompress data
Opkg's builtin decompression code is unsuitable to process nested archives as it uses a single shared state and relies on undefined seek behaviour for pipes. Rework the extraction logic to use the external gzip command as I/O filter for decompressing data and remove the builtin inflate code entirely. This shrinks the final opkg binary by about 4KB and results in less runtime memory consumption due to efficient use of vfork() and less copy-on-write operations in the forked child. Rework by Felix: create a thread that relays data to the gzip process instead of using a fragile poll loop Signed-off-by: Jo-Philipp Wich <jo@mein.io> Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/system/opkg/Makefile')
-rw-r--r--package/system/opkg/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/system/opkg/Makefile b/package/system/opkg/Makefile
index 8b8904a39a..cbd731f54c 100644
--- a/package/system/opkg/Makefile
+++ b/package/system/opkg/Makefile
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/version.mk
include $(INCLUDE_DIR)/feeds.mk
PKG_NAME:=opkg
-PKG_RELEASE:=15
+PKG_RELEASE:=16
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=http://git.yoctoproject.org/git/opkg