aboutsummaryrefslogtreecommitdiffstats
path: root/package/system/opkg/Makefile
diff options
context:
space:
mode:
authorJonas Gorski <jonas.gorski@gmail.com>2017-12-12 11:19:07 +0100
committerJonas Gorski <jonas.gorski@gmail.com>2017-12-13 13:38:19 +0100
commit1cfbd50ff4d401023748c9834845898618e72221 (patch)
tree66ea4dc3c362b902aaa54dd8468277a3b53f904b /package/system/opkg/Makefile
parenteeeee885fb497bb07041575b78fca4063145edb9 (diff)
downloadupstream-1cfbd50ff4d401023748c9834845898618e72221.tar.gz
upstream-1cfbd50ff4d401023748c9834845898618e72221.tar.bz2
upstream-1cfbd50ff4d401023748c9834845898618e72221.zip
package: move distfeeds.conf from opkg to base-files
All the relevant options used for distfeeds.conf are part of base-files, so it makes more sense to move the file there as well. This has the added benefit that the we can share the opkg package again, reducing the amount of target specific packages. Acked-by: Jo-Philipp Wich <jo@mein.io> Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
Diffstat (limited to 'package/system/opkg/Makefile')
-rw-r--r--package/system/opkg/Makefile14
1 files changed, 2 insertions, 12 deletions
diff --git a/package/system/opkg/Makefile b/package/system/opkg/Makefile
index a49021b119..7b49a3b111 100644
--- a/package/system/opkg/Makefile
+++ b/package/system/opkg/Makefile
@@ -7,11 +7,9 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
-include $(INCLUDE_DIR)/version.mk
-include $(INCLUDE_DIR)/feeds.mk
PKG_NAME:=opkg
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_FLAGS:=essential
PKG_SOURCE_PROTO:=git
@@ -25,15 +23,9 @@ PKG_LICENSE_FILES:=COPYING
PKG_MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
-PKG_FLAGS := nonshared
-
PKG_CONFIG_DEPENDS := \
CONFIG_SIGNED_PACKAGES \
- CONFIG_TARGET_INIT_PATH \
- CONFIG_PER_FEED_REPO \
- CONFIG_PER_FEED_REPO_ADD_DISABLED \
- CONFIG_PER_FEED_REPO_ADD_COMMENTED \
- $(foreach feed,$(FEEDS_INSTALLED),CONFIG_FEED_$(feed))
+ CONFIG_TARGET_INIT_PATH
PKG_BUILD_PARALLEL:=1
HOST_BUILD_PARALLEL:=1
@@ -93,8 +85,6 @@ define Package/opkg/install
$(INSTALL_DIR) $(1)/etc/uci-defaults
$(INSTALL_DATA) ./files/customfeeds.conf $(1)/etc/opkg/customfeeds.conf
$(INSTALL_DATA) ./files/opkg$(2).conf $(1)/etc/opkg.conf
- $(call FeedSourcesAppend,$(1)/etc/opkg/distfeeds.conf)
- $(VERSION_SED) $(1)/etc/opkg/distfeeds.conf
$(INSTALL_BIN) ./files/20_migrate-feeds $(1)/etc/uci-defaults/
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/opkg-cl $(1)/bin/opkg
ifneq ($(CONFIG_SIGNED_PACKAGES),)