aboutsummaryrefslogtreecommitdiffstats
path: root/package/system/opkg/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2016-09-14 20:50:35 +0200
committerFelix Fietkau <nbd@nbd.name>2016-12-26 11:17:32 +0100
commit0090adcd5c94adad2168cd9b338f45827533c81d (patch)
treed96a307b44525cb073daef4c86483b88b4344f18 /package/system/opkg/Makefile
parentd109d03198b4ff31d2e4259228a49fa1b3f10390 (diff)
downloadupstream-0090adcd5c94adad2168cd9b338f45827533c81d.tar.gz
upstream-0090adcd5c94adad2168cd9b338f45827533c81d.tar.bz2
upstream-0090adcd5c94adad2168cd9b338f45827533c81d.zip
opkg: vfork external gzip command to uncompress data
Opkg's builtin decompression code is unsuitable to process nested archives as it uses a single shared state and relies on undefined seek behaviour for pipes. Rework the extraction logic to use the external gzip command as I/O filter for decompressing data and remove the builtin inflate code entirely. This shrinks the final opkg binary by about 4KB and results in less runtime memory consumption due to efficient use of vfork() and less copy-on-write operations in the forked child. Rework by Felix: create a thread that relays data to the gzip process instead of using a fragile poll loop Signed-off-by: Jo-Philipp Wich <jo@mein.io> Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/system/opkg/Makefile')
-rw-r--r--package/system/opkg/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/system/opkg/Makefile b/package/system/opkg/Makefile
index 506677c6f1..4645dfd192 100644
--- a/package/system/opkg/Makefile
+++ b/package/system/opkg/Makefile
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/version.mk
include $(INCLUDE_DIR)/feeds.mk
PKG_NAME:=opkg
-PKG_RELEASE:=15
+PKG_RELEASE:=16
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=http://git.yoctoproject.org/git/opkg