aboutsummaryrefslogtreecommitdiffstats
path: root/package/system/opkg/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-04-14 19:00:14 +0000
committerJohn Crispin <john@openwrt.org>2015-04-14 19:00:14 +0000
commitcc9a392e4975dc25a0fab1c6f008ff03b025c426 (patch)
tree48ba8500f92a7eca5d832531f3bd1184a9241c5e /package/system/opkg/Makefile
parent0bd2710512e22039f4b7a20673dfbe90de82407c (diff)
downloadupstream-cc9a392e4975dc25a0fab1c6f008ff03b025c426.tar.gz
upstream-cc9a392e4975dc25a0fab1c6f008ff03b025c426.tar.bz2
upstream-cc9a392e4975dc25a0fab1c6f008ff03b025c426.zip
opkg: drop md5 in favour of sha256
Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 45437
Diffstat (limited to 'package/system/opkg/Makefile')
-rw-r--r--package/system/opkg/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/system/opkg/Makefile b/package/system/opkg/Makefile
index 4f30ec2114..1b1f3f19e4 100644
--- a/package/system/opkg/Makefile
+++ b/package/system/opkg/Makefile
@@ -89,11 +89,12 @@ EXTRA_CFLAGS += $(TARGET_CPPFLAGS)
CONFIGURE_ARGS += \
--disable-curl \
--disable-gpg \
+ --enable-sha256 \
--with-opkgetcdir=/etc \
--with-opkglockfile=/var/lock/opkg.lock
ifeq ($(BUILD_VARIANT),smime)
- CONFIGURE_ARGS += --enable-openssl --enable-sha256 --disable-usign
+ CONFIGURE_ARGS += --enable-openssl --disable-usign
else
ifndef CONFIG_SIGNED_PACKAGES
CONFIGURE_ARGS += --disable-usign
@@ -151,6 +152,7 @@ endef
HOST_CONFIGURE_ARGS+= \
--disable-curl \
--disable-gpg \
+ --enable-sha256 \
--with-opkgetcdir=/etc \
--with-opkglockfile=/tmp/opkg.lock